1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fallout 4

Discussion in 'PC Games' started by el-nino, Feb 27, 2020.

  1. el-nino


    Joined: May 8, 2013

    Posts: 82

    Location: Durham

    Hi All,

    I was thinking about reinstalling and playing some Fallout 4 again. But before I do I have an issue I need to resolve and wondered if you guys could help.

    I have a 9900k 32gb ram and a 1080 but the game constantly sticks on load screens for way too long. Does anyone know how to fix this?
  2. Haze


    Joined: Jan 10, 2007

    Posts: 3,190

    Maybe you won't still have after you have installed it
  3. AWPC


    Joined: Dec 8, 2005

    Posts: 9,620

    Like thousands of other players mine stopped working altogether on RTX Super 2060 but works ok on GTX1080 :rolleyes: Nvidia are having issues with the drivers for this!
  4. Calin Banc

    Wise Guy

    Joined: Aug 14, 2009

    Posts: 1,024

    This game loves fast RAM and SSD, I hope you have those. :)

    Just disable weapon debris. Apparently it's something that must be fixed by Bethesda itself (cannot be done via drivers) and since they've completely ignore it...
  5. FTM


    Joined: Dec 10, 2003

    Posts: 6,083

    Location: South Shields

    since I dropped my entire fallout 4 directory onto a new m2 ssd its become a much better experience...even with a couple of hundred mods!
  6. jpm

    Wise Guy

    Joined: May 14, 2004

    Posts: 1,227

    Location: Abertillery, South Wales

    This! Mine kept crashing running to the vault at the beginning of the game (2080) disabled this and all works fine.
  7. AWPC


    Joined: Dec 8, 2005

    Posts: 9,620

    Also disable the Creation Club mods if you have them as they also do not work properly on the RTX 2xxx series (depending on what CC mods you own!).
  8. Buffalo2102


    Joined: Jun 9, 2004

    Posts: 813

    There is a load accelerator mod on Nexus that sorts this out. Works for me anyway.
  9. Columbo


    Joined: Mar 26, 2007

    Posts: 8,457

    Location: Nottinghamshire

    As above use the load accelerator mod and also disable any FPS limiter you may have set separately in the GPU drivers (if you do this at all)

    Load times FO4 more specifically in the creation engine can be affected by the above. The mod essentially unbundles vsync from the load screen so the load times be alot quicker. It's the first mod I install whenever I play through again.
  10. AWPC


    Joined: Dec 8, 2005

    Posts: 9,620

    Disable All Creation Club mods if you have an Nvidia RTX 2xxx as well as Weapon Debris. Then it works just fine.

    Bethesda recently did something on the Creation Club DRM as they were accidently giving away all items for Free. Now you have to delete & redownload any CC & hope it works if you have a RTX 2xxx series GPU.
  11. oldestgregg


    Joined: Sep 4, 2011

    Posts: 5,649

    Location: Durham

    M.2 drive, or even a standard SSD for that matter, should sort that out.

    Just to confirm though, these are problems you had on your old system ages ago and have not tried it on your current build?
  12. loftie


    Joined: Oct 17, 2009

    Posts: 978

    I've always run FO4 on spinning rust and it's not taken what I'd consider to be a long time to load. Though I've not run it with graphics mods IIRC.

    Edit: Was implying maybe something is up, either FO4 being rubbish or something else.