iPhone Dropping carrier signal?

Soldato
Joined
11 Dec 2003
Posts
21,526
Location
Sol
Hey guys, I have an iPhone 4, bought with PAYG from o2 and moved recently to T-Mobile as the o2 signal was poor in my area, its JB on 4.0.1 and unlocked, the T-Mobile signal is pretty random at times, sometimes great aroudn the house, whereas my girlfriend's Nokia 5800 always has 4-6 bars and never drops signal, which is why I went with T-Mobile in the first place.

The carrier signa sometimes totally drops out going to "Searching..." then "No Signal" or whatever the actual term is. This happened both on my IP4 and my 3gs running 4.0 with JB and Unlocked to all networks.

Is it an iPhone/T-Mobile issue? Is it something I have done? I did a reset <> all settings and reset <> carrier settings at T-Mobile's request, but its still dropping off, and topping off that it has now erased the option for me to manually edit APN settings, the button for that in Settings <> general <> network is no longer there, I have less than no idea why!

If anyone could help me out with any advice, that would be great, just really not sure how to get things right, as said, other T-Mobile phones are flawless here, never drop carrier, occasionally go lower signal but never, ever lose signal fully, and I'm talking 2g, use home wifi so am not fussed about 3g at home.

Also seems to be happening at work, too, both postcodes are rated 4/5 for 2g and 3g connection (Taken with a pinch of salt, of course) but its starting to be a real liability already!

Any advice greatfully recieved!

Thanks!
 
Soldato
Joined
11 Dec 2003
Posts
21,526
Location
Sol
Yeah I have heard of, tested and experienced the issue, my free case from Apple should be with me today or tomorrow.

The phone is dropping signal if its in my pocket and I take it out only holding the top, on the top of a desk and unlocked etc.. Will obviously test it thoroughly, but right now T-Mobile have told me to do a few things which have messed things up whereby a few features of the JB that did work, now don't, if I could restore back to a blank 4.0.1 and start again I would, but as you can't now due to Apple verification, I refuse to go up to 4.1 and not be able to JB and therefore not able to use the custom themes and ringtones I use.
 
Soldato
Joined
15 Dec 2002
Posts
22,423
Location
In a cowfield, London, UK
Mine does this occasionally, even when I'm holding it lightly with my palm open so I don't think it's related to the antenna issue, of which I've yet to have any issues with also. I've not done any research into it though as it doesn't happen frequently enough.

I'm on o2 Simplicity 20, with a JB'd iPhone 4.
 
Soldato
Joined
11 Dec 2003
Posts
21,526
Location
Sol
Cheers Kainz, yeah its not that frequent but just so annoying, gonna try getting the case on it if it comes tonight and see how it goes, just hoping I can get it sorted, especially with the stupid now missing APN settings, too :(

Roll on JB for 4.1 so I can make a clean start!
 
Top