Mass Effect - Steam version running like a pos

Soldato
Joined
15 Dec 2002
Posts
22,558
Location
In a cowfield, London, UK
See, this is why I couldn't be ar*** with pc gaming years ago and it's come back to haunt me. Eventually purchased the game last night after Valve fixed the checkout issue and it downloaded fine.

I launched the game, setup my res of 1080p and I was away to watch the most sluggish, stuttering intro ever. I haven't even got beyond that point yet because it is so choppy. Dropping the resolution doesn't help, lowering details doesn't do sod all and v-sync makes no difference. I'm running out of options.

Already finished the game to the death on the 360 but just wanted to see what the PC version was like :/ Now I wish I hadn't bothered. Anyone got any ideas?

Specs:
C2D @ 3.7ghz, 4GB Ram, ATI 4870 1GB, Auzentech Meridian soundcard, Win 7. The game is installed on a raptor hard disk too :/
 
Soldato
OP
Joined
15 Dec 2002
Posts
22,558
Location
In a cowfield, London, UK
Nothing running in the background, latest ati drivers yes although they made no difference. Nothing running in the background, and the system is overclocked. I just can't see how that would be an issue given that there is no game that has given me such problems. Hell even Crysis doesn't stutter and choke like this does.
 
Associate
Joined
28 Jan 2008
Posts
1,249
It's always worth putting your overclocks back to default settings or simply lowering if problems occur. It dosen't always fix it, but overclocking can have wierd effects on games.

Re-installing can sometimes fix it too.
 
Soldato
OP
Joined
15 Dec 2002
Posts
22,558
Location
In a cowfield, London, UK
Downclocking to my stock 2.4ghz is the only open option left. I understand that Bioware put out a patch just a few days ago that has yet to reach steam. I wonder if that may help.
 

Aod

Aod

Soldato
Joined
7 Oct 2004
Posts
8,663
Location
London
Downclocking to my stock 2.4ghz is the only open option left. I understand that Bioware put out a patch just a few days ago that has yet to reach steam. I wonder if that may help.
unlikely - ordinary Mass Effect ran fine on my PC (nVidia 8800) on the day of release

it must be a problem with the steam version or your PC
 
Associate
Joined
3 Mar 2009
Posts
1,800
Ah yeah also, as its on Steam, try verifying the cache etc (right click, properties, local files, verify and defrag in there).
 
Soldato
Joined
27 Nov 2005
Posts
23,477
Location
Guernsey
I launched the game, setup my res of 1080p and I was away to watch the most sluggish, stuttering intro ever. I haven't even got beyond that point yet because it is so choppy.
The crysis intro does the same thing on my system in my sig...But the game runs fine........

Wait till your mass effect intro finishes and see if the game runs ok..
 
Caporegime
Joined
28 Oct 2003
Posts
30,295
Location
W'stchestershire
It does the same on my lowly laptop on WINDOWS 7 playing with the retail disc. The sound and video are out of sync in the intro video but corrects itself when you actually start playing. I wonder if it's a 7 issue... Anyone on XP or Vista with troubles?
 
Soldato
Joined
4 Dec 2002
Posts
14,519
Location
North Lincolnshire
vsync enabled or disabled? Also 0 problems here with a E1800 at 3gz and a 8800gt

edit sorry just noticed the vsync comment, only other thing to suggest would be try updating DX to the latest possible version
 
Soldato
OP
Joined
15 Dec 2002
Posts
22,558
Location
In a cowfield, London, UK
Currently v-sync its disabled. The game is running with software sound at the moment and things seem a bit smoother, but the choppiness is there. I've even tried it on Vista x64 as this is a dual boot system but it makes no difference.

This is just going to be one of those isolated gaming issues it seems. I played further into the game upto the Eden sections and gameplay itself is fine. It's just that the cutscenes are choppy. I'll try dropping to 2.4ghz later tonight I guess.
 
Soldato
Joined
4 Dec 2002
Posts
14,519
Location
North Lincolnshire
Can you knock down your video acceleration down 1 notch? That was an old trick to get things working but I know vista 64 with nvidia drivers has problems with it -.-
 
Associate
Joined
20 Mar 2006
Posts
383
Location
Manchester, UK
Possibly a codec interference issue? Try disabling/removing any codecs/codec packs you have installed. Windows 7 doesn't need codecs in any case since they're all built-in to Windows.
 
Soldato
OP
Joined
15 Dec 2002
Posts
22,558
Location
In a cowfield, London, UK
Possibly a codec interference issue? Try disabling/removing any codecs/codec packs you have installed. Windows 7 doesn't need codecs in any case since they're all built-in to Windows.
Good suggestion, as that was my first thought too since the FMV sequences are for the most part smacker/bink movies played back by the bink player. However I have no codecs as I use KM Player that has it's own decoding engine lol
 
Top Bottom