Monitor Display Issue

Associate
Joined
14 Jul 2010
Posts
42
Hi all,

My Samsung Synchmaster P2270HD screen goes fuzzy every time I push the screen resolution to anything above 1680x1050.

My graphics card is ATI Radeon 5800 series, i am not sure how to resolve the issue, and was hoping if anyone had encountered a similar issue?

Rgds,
 
Associate
Joined
5 Dec 2006
Posts
548
Location
Aberdeen
Have you tried to set the resolution to 1920*1080?

According to the specs of the monitor that is the native resolution. If you use a resolution that the monitor is not meant to use it can make things looks stretched/fuzzy/off.
 
Associate
Joined
14 Jul 2010
Posts
42
RE:

Hi,

Thanks for your reply. I tried to set the resoloution to 1920x1080 through windows and also ATI Catalyst Control Center to no avail.

I wonder if it could be anything to do with the monitor itself or HDMI cable...

Samsung are looking to replace this monitor with a new one, but said they have never come across this problem before.

Rgds,
 
Associate
Joined
5 Dec 2006
Posts
548
Location
Aberdeen
If you are getting a replacement for free and no one else comes along with a better idea I would go for that, then at least you can rule out the monitor.

Are you using up to date drivers? (not that I see this being a major problem).

Also without trying to offend you, are you sure that is the model you have?
 
Associate
Joined
14 Jul 2010
Posts
42
RE:

Hi,

Thanks again for your swift reply.

I am 100% sure that is the model, on the top left of the monitor (black rim) it says "SyncMaster P2270HD". (you havent offended me, sometimes it can be the user error) :)

I personally do not think it is the monitor as it displays 1680x1050, but any higher it goes fuzzy. I phoned overclockers and they said it might be old hardware or new running with the wrong hdmi cable. I find that this should not be a problem, and also i bought the bundle together from amazon.


I updated drivers through device manager, so looks like they are up-to-date.

Rgds,
 
Soldato
Joined
11 Oct 2009
Posts
15,153
Location
Greater London
My friend has the same TV as you. On HDMI when 1080p it appears fuzzy, DVI the damn thing kept crashing, and it was only on VGA the TV decided to behave. Everything became cystal clear and stable. I tested the TV on my PC too, still same results. So I assumed it was Samsung cutting back on certain components...

EDIT: I also have another friend with the same problem on the same TV thinking about it! Although he only tried HDMI and not DVI or VGA, and I couldn't help test it for him as he lives far away. Surely this must be a problem with this model then? For both of them though PS3 on HDMI seems perfectly fine :confused:
 
Last edited:
Associate
Joined
14 Jul 2010
Posts
42
RE:

Hi,

Thanks for your reply, it makes sense. I just tried changing the HDMI according to overclockers, but again it did not fix the issue.

According to Samsung they have never encountered this issue, however this maybe because they are trying to protect their reputation.

Rgds,
 
Top