Oculus Link Cable issue

Soldato
Joined
18 Oct 2002
Posts
7,605
Location
Sutton Coldfield
Bought the link cable to use my Quest 2 headset for ACC, project cars 2, etc..

Each time I plug it in I get the warning 'running at USB 2 speeds'.

I've tried it on another system (both AMD) and have the same issue.

Is there anything else I can try before I RMA this to OcUK? I didn't think USB cables could go wrong myself but this just doesn't want to work.
 
Caporegime
Joined
20 Oct 2002
Posts
25,598
Location
Oxon
latest AMD drivers ?

Radeon Software Adrenalin 2020 Edition 21.1.1 Highlights
Support For
Hitman 3™
Up to 10% increase in performance in Hitman 3, @4K Ultra settings, with Radeon™ Software Adrenalin 2020 Edition 21.1.1 on the 16GB Radeon™ RX 6800 XT graphics card versus the previous driver edition 20.12.1.RS-349
Quake II™ RTX
Fixed Issues
The recording and streaming overlay indicator may sometimes reset itself to the default position.
Performance Metrics Overlay size may intermittently reset or may not match values that are set in Radeon Software after performing a task switch.
The Radeon Software installer screen can sometimes display the incorrect release date of the Radeon Software version you are installing.
Performance Metrics Overlay may flicker during video playback on displays with HDR enabled.
Reflections in Grand Theft Auto V™ may fail to appear when ‘Reflection MSAA’ is enabled in the game settings.
PlayerUnknown’s Battlegrounds™ session timer may continue in Radeon Software even after the game has been exited.
DOOM Eternal™ may experience an application crash while gaming and having Steam™ overlay enabled.
Recorded content from Radeon Software may appear cropped or recorded at an incorrect resolution on Radeon RX Vega series graphics products.
The Samsung™ Odyssey G9 C49G95T may experience display or corruption issues when set to [email protected]
Anisotropic Filtering in Radeon™ Software graphics settings is not taking effect in DirectX®9 applications on RDNA graphics products.
Some displays such as the Sceptre C series or Samsung™ Odyssey G9 series may experience an intermittent black screen on Radeon RX 6000 series graphics products.
Oculus Link users may experience intermittent crashes on Polaris and Vega series graphics products.
 

koh

koh

Associate
Joined
8 Jul 2019
Posts
92
I am also having problems when using my USB c To USB c cable. Not the official one. I have mine connected to C port on RTX2080. When I run Oculus test it shows as USB 3 at 2.4gbps. When playing Dirt Rally 2 or AMS2 I start to get artifacts after few minutes play then get a cable disconnected message. I reduced SteamVR per eye resolution but still get same result. Strange thing is using WiFi & Virtual Desktop over my 5Ghz router I do not have the same problems. I'd expect a wired connection at 2.4gbps would outperform aWiFi connection. Anyone have any idea what's happening?

This is my cable

https://www.amazon.co.uk/gp/product/B08FY28Z8F/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1
 
Caporegime
Joined
20 Oct 2002
Posts
25,598
Location
Oxon
can you plug it into your PC rather than through the Graphics card ?
even if you have to get a USB-C to USB-A converter, i have a feeling it will be worth it (unless your never going to use a cable)
 

koh

koh

Associate
Joined
8 Jul 2019
Posts
92
Have thought problem might be due to using C port on GPU. Adapter would be my option as no C port on motherboard. Performance over WiFi surprisngly good but suspect might get slightly better image on a cable for racing/flight sims. Do you have any adapters in mind as may as well give it a go?
 
Caporegime
Joined
20 Oct 2002
Posts
25,598
Location
Oxon

koh

koh

Associate
Joined
8 Jul 2019
Posts
92
I've just installed the VR mod for Alien: Isolation and oculus link only option and it played okay. I had one disconnection but no artifacts/picture break up so puzzling. Can only think the encoding/decoding in racing cannot keep up with rendering game image. I'll give the adapter a go as not too costly if it does the trick plus useful to have it anyway.
 
Caporegime
Joined
20 Oct 2002
Posts
25,598
Location
Oxon
I've just installed the VR mod for Alien: Isolation and oculus link only option and it played okay. I had one disconnection but no artifacts/picture break up so puzzling. Can only think the encoding/decoding in racing cannot keep up with rendering game image. I'll give the adapter a go as not too costly if it does the trick plus useful to have it anyway.


whats your PC specs ?
 

koh

koh

Associate
Joined
8 Jul 2019
Posts
92
Specs
i7 3.60ghz
16GB ram
EVGA Black Edition rtx2080
W10 Pro 64 bit
Latest Nvidia drivers

Not top end but should be enough run AMS 2 & Dirt Rally 2 with graphics turned down. I've used it to run triple screens fine. Plus you'd expect load on PC would be more pronounced when streaming over Wireless than on direct cable.
 

koh

koh

Associate
Joined
8 Jul 2019
Posts
92
Yeah CPU is weak link yet runs games fine on single screen and triples aside from from ACC on unreal engine but most GPUs struggle to run ACC on triples. See if connecting to usb with adapter improves things. Like I've mentioned wired you'd expect would always outperform wireless with it's latency. PC is still having to encode/decode when using wireless so impacts on CPU so cable issue not make sense. Unless Oculus app & steamvr on cable are impacting more on performance than virtualdesktop & steamvr over ethernet & wireless.
 
Top Bottom