1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Parted Magic won't sleep issue

Discussion in 'Linux & Open Source' started by darael, May 16, 2018.

  1. darael

    Mobster

    Joined: Jul 10, 2010

    Posts: 3,643

    I honestly didn't know where else to post this, but I thought as Parted Magic is Linux based (as far as I can tell) then it should be here.

    My main reason for using Parted Magic is to erase SSD drives. I use the version included on UBCD, 2013_08_01. This has normally put my PC to sleep to erase SSD drives in the past. The only thing that I can think of that has changed is the BIOS - I have kept it up to date, but kept the settings the same.

    My motherboard is the Asus ROG STRIX H270F GAMING. It currently has the latest BIOS, 1010, from 14/04/2018. Just out of principle I ensure that it is up to date now and again.

    What happens is I boot from my UBCD USB drive, load Parted Magic and then I run the Erase utility from the desktop. The utility shows the drive as frozen, so I press the sleep button in the utility and the PC goes to sleep and the power light flashes a few times. After a second or two, the PC will wake itself up with a black screen. I am forced to either reset or power cycle the PC and it boots as normal - shows BIOS startup, then loads Windows.

    Any ideas or pointers?
     
  2. AmateurExpert

    Gangster

    Joined: Aug 7, 2017

    Posts: 376

    Location: location location

    Perhaps there's a newer version of Parted Magic you can try?

    Otherwise, you could try hot-plugging in the SSD after Parted Magic has started up. You may need to configure your BIOS to set the SATA port to support hot plugging (sometimes done by enabling "external SATA port" support on some motherboards).
     
  3. darael

    Mobster

    Joined: Jul 10, 2010

    Posts: 3,643

    I have tried different versions of Parted Magic, including the latest one. They all do the same thing.

    What's weird is that I choose to Suspend my PC in Parted Magic and my stays suspended. But when I wake it up, the same thing happens with the screen again - it just stays blank until I reset my PC.

    I might try and downgrade my BIOS and see what happens.