Process Explorer help...

Caporegime
Joined
7 Nov 2004
Posts
30,147
Location
Buckinghamshire
Hi all

Trying to use Process Explorer from Sysinternals to determine what a piece of software does on startup, and where it writes to etc.

Issue is, admin/staff can run the software fine, however students cannot, this is more than likely due to various group policy settings and a mandatory profile that the students use, so I'm guessing it's being stopped by a policy somewhere.

Any help is appreciated
 
Caporegime
OP
Joined
7 Nov 2004
Posts
30,147
Location
Buckinghamshire
What software is it? Failing that, log in as an admin and run it with Process Explorer open again

It's called Pro/Desktop and it's a gazillion years old. It worked before summer when everything was on XP, since the roll out of Windows 7 and the new mandatory profile, it doesn't work. It displays the splash screen then closes, so somethings blocking it. (Which I'm hoping is just access to a local directory)

I can run it as an admin, but how do I view where it is writing to?
 
Soldato
Joined
23 Apr 2006
Posts
6,460
Location
Nottingham
You said Staff can run it fine, are they on Windows 7 too? Also, if it runs fine when you run as admin, then would be a good time to use Process Explorer to see where it is writing to.
 
Caporegime
OP
Joined
7 Nov 2004
Posts
30,147
Location
Buckinghamshire
You said Staff can run it fine, are they on Windows 7 too? Also, if it runs fine when you run as admin, then would be a good time to use Process Explorer to see where it is writing to.

Yeah, what im wanting to know though, is how do i know where its writing to? :p is there an example i can follow somewhere? Never used the software before :(
 
Top Bottom