Pump suddenly really noisy

Associate
Joined
5 Apr 2008
Posts
1,526
Hi,
Normally my pump has been quiet (XSPC 750 Dual Bay resevoir/pump) But today it is really noisy, like 10 razors going at once!

Does anybody know why,
I was thinking of completely turning my pc upsidown (my pump/res) is in the drive bay.)

Would that be safe.
 
Associate
Joined
5 Apr 2008
Posts
1,526
there may be a bubble in the pump, because there was a trapped buble in the pump chamber (outside the intake) that may have got trapped in the pump.

Do you think that mite be a possibility
 
Soldato
Joined
13 Jul 2005
Posts
17,819
Location
Norfolk, South Scotland
Yes, it could well be a bubble. Try starting and stopping the pump repeatedly to try and clear it. Or move the case so the pump is low in the reservoir (if you understand me).

It doesn't surprise me that it should go - things generally die in the very early or very late stages of their projected lifespan.
 
Soldato
Joined
13 Jul 2005
Posts
17,819
Location
Norfolk, South Scotland
Yes, but it's in the bottom corner of the reservoir - tilt the PC so the pump is even lower relative to the top of the water. You're basically trying to shift the bubble, assuming that's what it is - so shake the case gently, rock it back and forth etc.
 
Associate
Joined
5 Apr 2008
Posts
1,526
Sadly, it's probably on it's way out. I'd check the levels, and if it's definitely submerged, I'd get ready to swap it out - before it dies, obviously.

I come back to this thread weeks later to tell you that I should have taken your advice but didnt. My pump has died:(Weep

Im going to send it back to overclockers.

Does anyone know wether it is ok to emty a w/c system then use a different coolant in it?
 
Top