1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Raspi CCTV system?

Discussion in 'Linux & Open Source' started by AHarvey, Aug 15, 2018.

  1. AHarvey

    Suspended

    Joined: Mar 6, 2008

    Posts: 8,861

    Location: Stoke area

    Hi,

    Had a couple of local chavs try the front door tonight just before I arrived home from work, the wife was home and a little worried about it.

    I have a raspi lying around and was thinking of setting it up as a remote CCTV system using a spare USB webcam.

    I'd like the ability to view remotely via phones when not at home, maybe get alerts about motion sensing activity.

    Ability to take photos and save them locally and remotely.

    motion-sensing and facial recognition would be a bonus.

    Any suggestions on prebuilt software I could use/start with and tinker with?
     
  2. maj

    Wise Guy

    Joined: Jul 19, 2010

    Posts: 2,153

    Location: Newcastle

    Take a look at motionEyeOS
     
  3. AmateurExpert

    Gangster

    Joined: Aug 7, 2017

    Posts: 376

    Location: location location

    Looks like an interesting project; I think it's a fairly common project idea so worth looking out for how-tos in order to see what problems others have already found and solved.

    For example: https://medium.com/@gonzalovazquez/...ing-up-your-own-video-surveilance-95444e0faad
    https://www.instructables.com/id/Build-Your-Own-Surveillance-Camera-With-Raspberry-/

    If you do get some good results, it would be nice to know which route you found worked for you.

    My Pi is already busy with VPN and automation duties and is only an original model B, otherwise I'd give this a go.
     
  4. AHarvey

    Suspended

    Joined: Mar 6, 2008

    Posts: 8,861

    Location: Stoke area

    trying to install MotionEye on top of an updated version of raspbian and it's just throwing dependancy errors

    The following packages have unmet dependencies:
    motion : Depends: libavcodec57 (>= 7:3.2.9) but it is not installable or
    libavcodec-extra57 (>= 7:3.2.9) but it is not installable
    Depends: libavdevice57 (>= 7:3.2.9) but it is not installable
    Depends: libavformat57 (>= 7:3.2.9) but it is not installable
    Depends: libavutil55 (>= 7:3.2.9) but it is not installable
    Depends: libswscale4 (>= 7:3.2.9) but it is not installable


    Trying to install these and they just refuse to :(
     
    Last edited: Aug 17, 2018
  5. PaulCa

    Gangster

    Joined: May 3, 2018

    Posts: 421

    Try Ubuntu MATE, or Google. I suspect that Raspbian's libavcodec libs are borked.
     
  6. AmateurExpert

    Gangster

    Joined: Aug 7, 2017

    Posts: 376

    Location: location location

    What errors are you seeing?

    Doesn't "apt search libavcodec57" show something like:

    libavcodec57/stable,now 7:3.2.10-1~deb9u1+rpt2 armhf