Razer Lachesis cursor jumping

Associate
Joined
7 Oct 2007
Posts
750
Hi,

I've had the Razer Lachesis mouse for a while now, it's a great mouse but every now and then the cursor jumps, it's never really bothered me but now it's starting get annoying.

I have the latest firmware and driver, which is supposed to fix the problem but has done nothing. I'm also using the razer destructor surface.

Does anyone have the same problem and know of any fix? To be honest i'm considering just getting a new mouse if it can't be fixed.

Any help is appreciated, thanks.
 
Associate
Joined
21 Dec 2005
Posts
1,464
I had the Razer Lachesis before, had the same problem. the laser is just too sensitive. Get a logitech.
 
Associate
Joined
31 Jul 2009
Posts
2,188
Location
127.0.0.1
When i've had that problem it was because i was using it on a weird surface. You using a mouse pad with it? Try turning down the sensivity a bit
 
Soldato
Joined
30 May 2009
Posts
4,619
Location
Maidenhead
I was away to say update the firmware, until I read you had updated. Lack of sleep fails.

Anyway, I can't think of anything else you could try. I have a Lachesis and it all seemed to work fine for me after flashing the 1.91 firmware, and using drive 1.1.

Maybe try reflashing the firmware, and see if that works? If not, you have may have to get a new mouse. It's great when it works, but I hated mine before I fixed it.
 
Associate
Joined
11 Sep 2009
Posts
2,165
Location
UK
LOL, i had this problem, you need to ensure there is no dirt anywhere near the laser, clean all round it, when my mouse plays up and starts not moving smoothly its because there is dirt near the laser.
You also have a 2 year warranty on this and send it back if it's bothering you, i am in the process of sending mine back as the button below the wheel has stopped working.
 
Top Bottom