1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RHEL 7.5 - Kickstart - ipa-client script issue

Discussion in 'Linux & Open Source' started by opethdisciple, Aug 7, 2018.

  1. opethdisciple

    Capodecina

    Joined: May 18, 2010

    Posts: 16,674

    Location: London

    I'm hoping someone has some experience with this.

    The issue is well documented but I cant find a well documented solution.

    From RH Satellite 6 I have a kickstart that can successfully deploy RHEL 6 hosts. Towards the end of the script it runs a snippet (another batch of code) that runs a automated ipa-client install script as well as sets up puppet and does an initial puppet run.

    This works perfectly.

    I am now tying to make the Satellite RHEL 7 aware.

    The kickstart with a few minor modifications works. However I start running in to issue with my ipa-client install and puppet script.

    Puppet fails because of failures with the ipa-client install. The ipa-install fails as it complains that the certmonger service isn't running. If I try to start the certmonger process as the Kickstart happens I see a message flash up that it is ignoring the request as running in a chrooted environment.

    Any one know how I am meant to automated the running of scripts from a RHEL 7 Kickstart?

    I have tried running the snippet from a %post --nocharoot block but it still doesn't work.

    I have sort of come to the conclusion that I need to set up a systemd unit file that will run the script on first boot and then presumably delete it's self.

    Seem like the right approach?

    The only issue I see with this is I need some visual representation that a puppet run is in progress when the machine boots for the first time.
     
    Last edited: Aug 7, 2018
  2. memyselfandi

    Sgarrista

    Joined: Oct 10, 2005

    Posts: 8,179

    Location: Nottingham