1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Search Console issue

Discussion in 'HTML, Graphics & Programming' started by ChroniC, Sep 30, 2018.

  1. ChroniC

    Sgarrista

    Joined: Oct 18, 2002

    Posts: 8,837

    Probably the best forum to ask, since it's probably used by a fair amount of devs here.
    I have a html 5 site that I have indexed in search console, but recently there have been crawl errors 404 for non existent links.
    The site is friends plumbing company and the links are random keywords followed by aspx.
    Something like boiler_service.aspx or contact_us_boilers.aspx. Strangely it seems to be words that are used throughout the site but there is no aspx files or javascript that creates any such links. I wonder if some malicous code has been added in but I have downloaded the public folder and searched the whole folder using Sublime for any aspx files or similar.
    I can find nothing that would cause this.

    Would anyone have a clue why something like this might happen?
     
  2. AHarvey

    Sgarrista

    Joined: Mar 6, 2008

    Posts: 8,929

    Location: Stoke area

    I had similar issues with a clients wordpress site, lots of random links added that threw up errors.

    I had to restore from a backup in the end.

    What you could do if you have the original files would be to compare filesize against the most recent download, that will highlight where the problems lie.

    Could you post a link to the site and the list of 404 errors?
     
  3. ChroniC

    Sgarrista

    Joined: Oct 18, 2002

    Posts: 8,837

    Think I may found the solution. Have to wait till its recrawled. I deleted a link to a checkatrade apsx, showing a review score. Think that site must have been the cause of the dead links. Dunno.

    I've modified the files so much that comparing them would be a waste of time.