1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sleep Study CPU Usage and System Interrupts in Windows 10

Discussion in 'Windows & Other Software' started by spirits247, Apr 30, 2017.

  1. spirits247

    Hitman

    Joined: Jan 29, 2007

    Posts: 712

    I know most people don't have this issue but I thought I'd post it here because I've come across it a few times now in Windows 10 and it can take a while to find an answer if you're not aware (anyone searching google hopefully).

    I've come across a few PC's (Desktops and Laptops) where the CPU usage was pegged at maxing out one core and also Disk usage was constantly writing to the SSD (not good) or hard drive.

    After looking into resource monitor, you can see it's the "System" and "System Interrupts" that's causing it, writing loads of information to a log file called SleepStudy/UserNotPresentSession.etl on the C drive (huge clue there!).

    Turns out that if certain PC's or laptops (perhaps hardware specific) don't wake up properly or there is a powercut when it was sleeping, next time you boot the system keeps logging all the system devices that would be using power in sleep mode.

    Problem is, the computer is no longer sleeping so that would be a huge amount of devices and interrupts it starts to log! Sleep study continues when the user IS present and in a fully powered up state - hence the huge logging and system interrupts being hammered.


    My brother complained of a slow dual I3 series 4 desktop PC, it has literally written GBs of data to the SSD and been maxing out one core and hammering the interrupts process until I put it to sleep and woke it up again then everything was fine (shutdown/reboot didn't stop the logging)

    Just a heads up as it seems this sleep study has a few bugs still in Windows 10.
     
  2. yashiro

    Mobster

    Joined: Dec 9, 2003

    Posts: 3,512

    Location: UK

    Basically, open perfmon and disable the UserNotPresentTraceSession if present.
    Right click the entry. Properties. Trace Session tab. Untick Enabled if it's active.

    If that doesn't work you could edit said loggers and remove any triggers or uncheck the log mode settings. Probably worth doing to ScreenOnPowerStudyTraceSession too.

    If that doesn't work you can just set files in C:\Windows\System32\SleepStudy as read only.

    I think the problem here is that something is turning this log on at boot all the time, hence recreating the defaults even if edited. The read only trick is probably the easiest fix.
     
    Last edited: Apr 30, 2017
  3. spirits247

    Hitman

    Joined: Jan 29, 2007

    Posts: 712

    Thanks for the tips, I've set that file to read only in case it happens again for the sake of the poor SSD.
     
  4. Danny75

    Sgarrista

    Joined: Aug 26, 2013

    Posts: 7,681

    Thanks to both for starting this thread and for the fix. Just happened to me on Win 10 Pro. 14GB worth of writes in one hour. It occurred while playing GTA V, which is what someone in the SuperUser forum mentioned as well. Have made the relevant file in SleepStudy read-only and rebooted.
     
  5. Sage Badolato

    Associate

    Joined: Dec 31, 2018

    Posts: 1

    And thank you for confirming this about GTA V.. I was wondering why my i5-8300H kept getting pegged, and my NVMe would instantly go to 100% usage while alt-tabbed. Happened out of no where after many days of gameplay on the new laptop. It’s a fresh install of 10 as well.

    Though in order for the read-only settings to apply correctly for me, I had to take ownership of the folder from system and give it to much user, then place the entire folder into readonly mode.
     
  6. Danny75

    Sgarrista

    Joined: Aug 26, 2013

    Posts: 7,681

    You're welcome. I've found I have to repeat that process every time there's a big Windows feature update. Feature updates re-enable stuff like that, disabled services etc.