Speaker/Amp config for OS(2ch Music/ 5.1ch Games) and Bitstream (FFDSHOW Videos)

Associate
Joined
30 Jul 2007
Posts
1,181
ati 5850
win 7 64bit
onkyo 808 receiver
ati hdmi audio set as default card with 5.1 config
ffdshow set to bitstream all audio streams in video files

I am experiencing a few anomalies, any suggestions please on the following.

1. When the amplifier is switched off the PC say no speakers or headphones plugged in. Is this expected?

2. when receiving a skype call during video playback, the amp is in dts mode. thevideo stops and after a timeout the amp will (sometimes) switch decoding mode to stereo mode (the video has stopped sending the dts signal). The swap of decoder mode causes the pc to loose the amplifer and skype errors on an issue with the sound card.

3. when playing 2 ch music (flac) should the amp switch to stereo mode. I am not sure that amp treats a bitstream from a video, the same as a sound out put say of media player. ie it is reliable with a bitstream to choose the right mode, but from media player (eg) it is not reliable because the pc is set to 5.1 speaker config. Perhaps i should try setting the pc to stereo and then check that bitstreams still work? But if i set the pc to 2 speakers i dont think multi channel games will work. Perhaps i need a utility that will be quickly swicth speaker configs on the OS?


4. Ive heard about a realtek driver for the ati card, should i be using the realtek driver?

any ideas much appreciated.
 
Top Bottom