1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Steam games - Dont run?

Discussion in 'Linux & Open Source' started by FatRakoon, May 13, 2020.

  1. FatRakoon

    Capodecina

    Joined: Oct 18, 2002

    Posts: 10,106

    Location: Behind you... Naked!

    I am not quite sure why this has started to happen?

    My Main Linux PC is currently my old AMD 9590 with an ATI RX480 and 32GB RAM.
    It has Kubuntu 20.04 installed as of a few days ago, however I was having the same issue with Mint Cinnamon 19.3 and KUbuntu 19.10 and also Fedora KDE 31 before that, in that order.

    I have it setup fairly simply

    sda = 240GB SSD as /
    sdb = 2TB HD as /home
    sdc = 2TB HD as /home/data

    I have a folder thats currently /home/data/Steam and I have that setup as the default downlaod folder for the steam games.

    I might also add, that my Linux Laptop is setup in exactly the same way.

    Now, at this time I would also say, that the software packaging has 3 versions of STEAM on it,. plus I have also tried the downloaded version from steampowered and one version does NOT see the extra /home/data mounted drive, so thats a problem, but the others do.

    I have also gone through the folders, looking for the older steam files.. The list is given in the .deb installer, and I have manually removed each and every file and folder manually to make sure that I got rid of everything, including the two in the home folder itself.

    But what happens, is that I install steam, and I click on the game, and after a few moments, of it clearly doing something, the play button lights up again, showing me that its ready to play.. I click it and it repeats itself.

    Its just cycling about.

    Normally, I just use tha same files, but I have now uninstalled and reinstalled the offending games and no, its made no difference?

    The Laptop is fully working though?

    So, I copied the fiels from the laptop to the desktop, but its still wont work?

    The ONLY difference that will make any possible reason for it to fail is that the Desktop is on an AMD CPU & GPU and the Laptop is Intel / nVidia

    The CPU wont be anything, but the GPU?

    Im going to have to try plopping an nVidia into it sometime to try that, but its not easy for me.

    Anyone have any thoughts?
     
  2. pete910

    Mobster

    Joined: Oct 3, 2013

    Posts: 2,753

    Not sure why you have/need 3 versions of steam, may be remove them and install the one in the package manager(Sorry, don't use debian based so no clue what it's called)

    Is it all games are just a few ?

    After you copied the files did you check/set the permissions?

    Run steam in a terminal and post what errors are shown.
     
  3. FatRakoon

    Capodecina

    Joined: Oct 18, 2002

    Posts: 10,106

    Location: Behind you... Naked!

    No, sorry, I dont need 3 versions. I was only explaining that there ARE 3 versions in the software managers, and I have tried all 3, just in case, plus the one from SteamPowered themselves.

    Dopnt truly know why there are 3, but
    1. Is the installer for the full app
    2. Seems to be the full app
    3. FlatHub version

    As to whether 1 and 2 are any different, I dont know? - I dont really know why the hell there is these in there, but there you go!

    I am also not sure, but they do install the steam folder into different locations too! - Or at least I found that there was a steam folder and a .steam folder and also the games were in 2 locations too, so maybe... Oh I dont know? Perhaps thats what happebned with all the installs and messing about I have done in the recent and thats why they went iffy?

    I have ZERO clues as to what I have done, but what I have done since... Well, for a long time now, is kept my /home partition untouched, so that when I do a frsh install, I only format the SSD and this has just the EFI Partition, the root and a Swap and so I backed up my important stuff and just formatted the /home and /home/data ( two diferent drives ) for a change, and I reinstalled steam and it works just fine.

    Yes, its complete overkill but it was getting on my pip. It shows that there was obviously a rogue file or two that was causing issues.

    And, just to note, no, it was only a few apps... Dawn Of War Dark Crusade, SoulStorm and Dow2 and also 3 as well as a couple of others, but most still worked fine. Im just wanting to play those thats all.
     
  4. pete910

    Mobster

    Joined: Oct 3, 2013

    Posts: 2,753

    Got ya now, Not sure what/where your particular distro has them install to tbh

    I have a similar set-up regards partitions.

    Code:
    /dev/nvme0n1p1 on /
    /dev/nvme0n1p2 on /home
    /dev/nvme0n1p3 on /boot/efi
    /dev/nvme1n1p1 on /home/pete/.local/share/Steam
    /dev/sda1 on /home/pete/Games
    /dev/sdb1 on /home/pete/Videos
    I don't have them games so not in a position to test at my end however run steam in a terminal like I suggested. May spread some light on the issue.
     
  5. Cithan

    Associate

    Joined: Feb 5, 2012

    Posts: 20

    Location: London

    Try launching `steam` from the command line then start up a game. You'll see a bunch of output and quite possibly some type of error message that might give you some clues as to what is going on.

    I thought the Nvidia drivers were generally a lot better supported than the AMD ones?