Ubuntu Server.... Can't format, partition discs

Associate
Joined
6 Mar 2011
Posts
271
Location
London
I'm setting up a new media server using Ubuntu Server. I've installed the OS on an ssd and it's all up and running. I'm accessing it via a virtual desktop and or Webmin.

When I add a drive ( the content drives ) I can see the drive in the disc manager in both Webmin and the virtual desktop but I can't do anything to it. If I try to partition or format the drive I get an error saying 'Not authorized'.

After much searching I think the problem maybe to do with Ubuntu thinking the disc is part of a RAID setup.

I've checked in the bios and RAID isn't setup. The only solution I've found on the Ubuntu formum is to stop dmraid running on startup but as far as I can see I don't have dmraid installed ?

Any ideas ?

Would say I'm a bit of a Linux noob and although I can muddle through my knowledge isn't exactly deep ;)
 
Soldato
Joined
27 Oct 2006
Posts
6,970
Location
London
I was going to suggest fdisk but that might be a little too risky for a noob

Install and run gparted ... maybe your disk is part of array. delete all partitions / references to RAID member
 
Soldato
Joined
21 Jun 2004
Posts
2,768
Location
Berkshire
From ssh run
cat /proc/mdstat

Should say no devices, otherwise it thinks its part of a raid. mdadm will pick up intel snf other fake onboard array's as well as it's own.

It's also possible you have some old raid metadata from your mobo on the drive, in which case if you look at "man dmraid" you will see the switch to remove that info.
 
Soldato
Joined
10 Oct 2005
Posts
8,705
Location
Nottingham
Isn't it the case that you are logging into the virtual desktop as a non-root user and then trying to do tasks against the new disks without escalating your privilege level up to root?

Hence the user you are using doesn't have the permissions to act against the device hence is not authorised to carry out the task?
 
Associate
OP
Joined
6 Mar 2011
Posts
271
Location
London
Thanks for the replies :)

I was going to suggest fdisk but that might be a little too risky for a noob

Install and run gparted ... maybe your disk is part of array. delete all partitions / references to RAID member

Just tried that... gparted shows in the application on my virtual desktop but won't run... just downloading the live version to try.

From ssh run
cat /proc/mdstat

Should say no devices, otherwise it thinks its part of a raid. mdadm will pick up intel snf other fake onboard array's as well as it's own.

It's also possible you have some old raid metadata from your mobo on the drive, in which case if you look at "man dmraid" you will see the switch to remove that info.

Ran cat /proc/mdstat and got this....

Capture-4.png


Don't think it's old data... it's a new drive. Also tried it with an old one and I get the same error ?

Isn't it the case that you are logging into the virtual desktop as a non-root user and then trying to do tasks against the new disks without escalating your privilege level up to root?

Hence the user you are using doesn't have the permissions to act against the device hence is not authorised to carry out the task?

Quite possibly. I've just realized that although I've done a few Ubuntu installs I've never added a drive to any of them :o:confused:
 
Associate
OP
Joined
6 Mar 2011
Posts
271
Location
London
Well using gparted live I've managed to format and partition the drive. I couldn't mount it through the virtual desktop but I could with Webmin.

I can see the drive in the virtual desktop and navigate through the directories until I reach the 'lost and found' folder when I get the not authorized error message again.

So it looks like memyselfandi is right and the problem lies with how I'm logging into the virtual desktop?

I'm using vncserver .... any ideas on what to do now?
 
Soldato
Joined
10 Oct 2005
Posts
8,705
Location
Nottingham
I'm assuming this drive needs to be their permanently ... I'd suggest adding the drive to the fstab so it's mounted automatically at boot and changing the ownerships on it so that your user can write to it normally.

I'd suggest reading the following link:
https://help.ubuntu.com/community/InstallingANewHardDrive

from the "Modify Reserve Space (Optional)" point onwards, (I'm assuming that you've formatted the drive as ext3). That should tell you how to set the drive's filesystem to be available to the your user automatically on boot.
 
Associate
OP
Joined
6 Mar 2011
Posts
271
Location
London
Thanks for the link and I seem to be off and running again in the right direction :) I've managed to get gparted to run on my virtual desktop ( gksudo rather than sudo ) . I haven't had a chance to work through the link but at least I'm making progress again and have a much better understanding of how users and permissions etc work :)
 
Top Bottom