USB storage showing up in 'Drive Management' but not in 'My Computer'...

Associate
Joined
5 Sep 2003
Posts
760
Location
Cardiff Geordie
Ok, let me begin by saying I don't know if this is in the correct forum as I don't really know where the problem lies, but I imagine it'd be with Windows. I'm running XP Pro btw.

SO, for the past few weeks, whenever I've connected any form of data storage device to my computer (via USB), it has failed to show up in 'My Computer' as an external drive or 'mass storage device' with its own drive letter like it used to. We're talking stuff like compact flash cards in an external USB card reader, my HiMD minidisc unit and a memory stick in my PSP. If i check in 'Disk Management', the drives usually show up, but I can't access them unless I assign them a drive letter, and it won't let me assign a drive letter without rebooting. After a reboot, whatever I had connected still doesn't show up in My Computer, but i can then access it through Disk Management, right-clicking on the drive and then clicking 'open'.
The problem compunds in that if anything that's not disk management wants to access my external peripherals, such as my PSP media program or my minidisc media program, they can't see the drive as it's not in My Computer.

Does anyone have any idea why my computer might have stopped automatically assigning drive letters to external things as they're connected?
 
Last edited:
Man of Honour
Joined
15 Mar 2004
Posts
28,143
Location
Liverpool
It could be that your machine fails to recognise the format of the disks.

Either that or, you need to have service pack two installed which has better USB support. I had similar problems which then went away after the pack was installed.
 
Associate
Joined
26 Apr 2006
Posts
700
you seem to have 2 threads on this problem :p , i replied on the other thread with..

"Do you have a G: or F: already ? as we have a problem with some usb drives at work defaulting to F: or g: - if this is the case go into disk management again and assign the usb drive a new drive letter."
 
Associate
OP
Joined
5 Sep 2003
Posts
760
Location
Cardiff Geordie
yea i do have two threads, wasn't really sure if i'd put the first one in the right forum, sorry! :)

Right, I do have SP2, and the problem has only happened recently, although i'm at a loss as to what might have caused it. The format of the disks shouldn't be the problem, as I can gain access to them through disk management, and they're all simple enough file structures, mainly FAT.

G: and F: are my optical drives. I've tried re-lettering the usb drives (when they've finally been accessible) to random letters like X: and Y:, but no luck. I know the PSP used to come up with H, I or J depending on what virtual drives i had activated, and it seemed fine with assigning itself an available drive letter. I could try assigning all my hard/optical drives to high-alphabet letters (like Z Y X) and see if the USB drives find it easier to assign themselves that way, but I don't think it'd make any difference.
 
Soldato
Joined
12 Sep 2003
Posts
10,033
Location
Newcastle, UK
I had a look around on google, and the reason they arn't showing in My Computer is because for whatever reason a drive letter isn't being assigned. So, now "we" just need to figure out why a drive letter isn't being assigned when the removable storage is connected. Hmm! :confused:

Have you tried re-installing the chipset drivers to see if that fixes the problem?

Try getting TweakUI from Microsofts site to un-hide all the drive letters and see if the drives appear then?

Cheers! :)
 
Associate
OP
Joined
5 Sep 2003
Posts
760
Location
Cardiff Geordie
I have tried reinstalling the chipset drivers, just the other day; i thought it might be something with the USB2 drivers that it came with, but it did nothing. I'll try this TweakUI program. So it's on the Msoft site you say?
 
Soldato
Joined
12 Sep 2003
Posts
10,033
Location
Newcastle, UK
Associate
Joined
26 Sep 2005
Posts
617
I've seen this happen on a number of PC's , the problem has started when people have just pulled out the USB lead instead of closing the device down , Safely Remove hardware , icon at the bottom of the taskbar. I've known this to disable the USB ports .I've had to re-install the OS to make it right again . I'd be curious to know if there was a quick fix myself.
 
Associate
Joined
18 Aug 2003
Posts
868
Location
S Yorks
I had exactly the same problem at work with my memory stick that did exactly as your PSP is doing. I had to alloacte it a drive letter that was never used by any of our network shares, and then delete my profile - when the profile was rebuilt, that seemed to fix it, but i dont really know why tbh!
Hope that helps.
 
Associate
OP
Joined
5 Sep 2003
Posts
760
Location
Cardiff Geordie
PROBLEM SOLVED!!

After Googling the error message ''partition or volume is not enabled" that Drive Manager gave when trying to assign drive letters, I came across a user who'd had exactly the same problem and found out that it was DaemenTools, the popular image mounting software, that had installed some drivers that were stopping the system from assigning drive letters and mounting drives. IT turned out that removing a "dtscsi.sys" driver and also sptd*.sys files in 'WINDOWS\System32\Drivers' and then rebooting solved the problem. About bloody time, too. Cheers for the help guys, let anyone else who posts with this problem know!
 
Back
Top Bottom