Wifi keeps disconnecting

Associate
Joined
21 Mar 2015
Posts
292
Everything seems good with this new build except the wifi keeps disconnecting and I can't figure it out.

Windows 10, wifi adapter from the bay.

When I start it up it's disconnected the connects, perfect. Then I open Steam and continue a download which is fine for maybe 3 minutes then I notice the time remaining getting longer and longer until I look to the taskbar and the icon changes to disconnected.

I'll try and reconnect but it says it can't, so I turn the wifi off and on and try again.

I've exhausted my Google-fu, been through all the settings like turning off the 'allow this device to turn off' thing and been through changing between public/private which seemed to make it work.

It's a new build so I'm pretty sure I've downloaded all the drivers, been to the MSI site, AMD etc. I even tried a driver thing where it scans the PC and sees what you're missing so you can download it, I forget the name.

My trouble is the adapter says it's unbranded and there's no name on it. The description says the same but also says TP-Link TGR1900 but all I get for that is a router hub of some sort. I just don't know where to go from here.

EDIT: I have it set up to one of my two monitors so I'm sure it's not my own wifi as my own PC stays connected while this one drops out.
 
Associate
OP
Joined
21 Mar 2015
Posts
292
Have you tested it installed directly into one of the computer's USB slots to rule out the monitor connection?


If the above fails i would try a different adapter.

It's plugged into the IO at the back if that's what you mean?

EDIT: I've just removed it from there and plugged it into one of the case USB ports at the front and it connected by itself o.O

EDIT 2: and it's gone off again lol lasted maybe 10 mins
 
Last edited:
Soldato
Joined
29 May 2005
Posts
4,295
Sounds like some kind of power saving setting is triggering the wifi card to power down or go into energy saving mode.

go into bios make sure those power saving mode options on peripheral or PCIe devices are switched off.

then go into windows power option and make sure Link State power saving is switched off or set to max performance etc.

the go into network sharing center and right click the wireless lan adaptor and click property and configure device make sure all performance related settings are set or max performance and power savings are switched off. Then make sure you know your wifi band and select a different wifi band with less interferences on that wifi card as well as the router

then make sure your connection is as close to each other as possible. The less brick or floor the signal has to travel the better.
 
Associate
OP
Joined
21 Mar 2015
Posts
292
Sounds like some kind of power saving setting is triggering the wifi card to power down or go into energy saving mode.

go into bios make sure those power saving mode options on peripheral or PCIe devices are switched off.

then go into windows power option and make sure Link State power saving is switched off or set to max performance etc.

the go into network sharing center and right click the wireless lan adaptor and click property and configure device make sure all performance related settings are set or max performance and power savings are switched off. Then make sure you know your wifi band and select a different wifi band with less interferences on that wifi card as well as the router

then make sure your connection is as close to each other as possible. The less brick or floor the signal has to travel the better.

I don't have a card it's more of an adapter or dongle if you will, not sure if that makes a difference. It's right next to my PC and that stays connected so I know it's not too far from the router or anything, it's a gift for Christmas anyway so it's not staying here but I will definitely try those points tomorrow and hopefully they work! Thanks!
 
Soldato
Joined
29 May 2005
Posts
4,295
same thing applies to USB dongle. in power saving make sure the USB power saving is switched off.

and go into the network connection properties and make sure allt he power saving are switched off and max perf is set on.

also if you havea USB extension cable then use that to get your dongle as far away from the back of the PC as possible. also moving the dongle to the front of the PC helps.

PC - lots of electronic components generate its own EM waves and cause interferences.
 
Associate
OP
Joined
21 Mar 2015
Posts
292
same thing applies to USB dongle. in power saving make sure the USB power saving is switched off.

and go into the network connection properties and make sure allt he power saving are switched off and max perf is set on.

also if you havea USB extension cable then use that to get your dongle as far away from the back of the PC as possible. also moving the dongle to the front of the PC helps.

PC - lots of electronic components generate its own EM waves and cause interferences.

I've bought a new dongle tp-link ac600, everything seemed fine, turned the pc off and on a few times and it connected straight away. Then it disconnected but I remembered with it being new I had to uncheck the 'allow this device to turn off'.

Fine for 5 mins after a restart then it cut out but it reconnected itself which it hadn't done before.

I've gone into power saving and disabled usb selective suspend but I can't find the network connection properties power saving you mentioned
 
Associate
OP
Joined
21 Mar 2015
Posts
292
I always figured the WiFi dongles went into the motherboard at the back, a cleaner look and the front ones are free for your other things. I didn't know they might work better at the front

EDIT: 9 mins after a restart it's disconnect again but now the little usb icon is showing, the 'safely remove hardware and eject media' one. Its reconnected by itself but I don't get why it's dropping out

EDIT 2: Lasted 20 mins this time :(
 
Last edited:
Soldato
Joined
29 May 2005
Posts
4,295
I always figured the WiFi dongles went into the motherboard at the back, a cleaner look and the front ones are free for your other things. I didn't know they might work better at the front

EDIT: 9 mins after a restart it's disconnect again but now the little usb icon is showing, the 'safely remove hardware and eject media' one. Its reconnected by itself but I don't get why it's dropping out

EDIT 2: Lasted 20 mins this time :(
I would recommend get a USB extension cable or get a PCIE card for wifi with cables to move the antenna away from the Pc. Also try different USB ports and set your Pc power option to performance or max performance whatever it is. Disable hibernation sleep etc. Ensure your driver is up to date.

with regard to network adaptor settings, you need to go into network sharing centre and find your wifi adaptor and right click and go through its properties.

Google “how to change wifi adaptor device properties” for a video walk through.

lastly what encryption are you running with the wifi? Also are you using static IP or DCHP? Any funny vlan going on?
 
Associate
OP
Joined
21 Mar 2015
Posts
292
I would recommend get a USB extension cable or get a PCIE card for wifi with cables to move the antenna away from the Pc. Also try different USB ports and set your Pc power option to performance or max performance whatever it is. Disable hibernation sleep etc. Ensure your driver is up to date.

with regard to network adaptor settings, you need to go into network sharing centre and find your wifi adaptor and right click and go through its properties.

Google “how to change wifi adaptor device properties” for a video walk through.

lastly what encryption are you running with the wifi? Also are you using static IP or DCHP? Any funny vlan going on?

Last night I uninstalled the dongle and installed it using the driver from the site which is older than the one that auto installed and it seemed to be running okay.

Now I've started it up and noticed the dongle light is a solid green rather than flashing like yesterday and it didn't connect at all, not even at startup. I've changed the power setting from Ryzen to balanced, and wireless adapter settings power saving mode to max and disabled usb selective suspend setting. So far it doesn't connect as fast on startup as it did but it's been connected for 45 mins so far so that's something. I tried the dongle in the front usb ports last night and still had issues.

I can't buy anything else for this build they're coming to collect it Christmas Eve, I was given a budget and I already went a bit over thanks to the GPU shortage and this new dongle has come out of my own pocket too. I've never had a problem with WiFi or eventually found a fix for my other builds there's got to be something I can do for this one

I don't know about encryption or things like that sorry
 
Soldato
Joined
22 Jun 2006
Posts
5,279
I have some old adapters and they usually overheat and disconnect if I download anything from Steam, but they work fine (even when playing HD video) if I place them behind the case exhaust fan. They also overheat and disconnect if they're placed in a USB 3 port, so it has to be USB 2.
 
Associate
OP
Joined
21 Mar 2015
Posts
292
I have some old adapters and they usually overheat and disconnect if I download anything from Steam, but they work fine (even when playing HD video) if I place them behind the case exhaust fan. They also overheat and disconnect if they're placed in a USB 3 port, so it has to be USB 2.

That's weird that they're Steam specific like that, I only opened Steam as something to do to check connection but maybe it was similar. I don't think this one has USB 3 at the back though but I could be wrong.

Tonight I had the PC on for 4 hours with no disconnect! It does take maybe 30seconds from desktop for it to connect but I'd rather gift a PC that does that than one that keeps disconnecting for him mid-game. Will test again tomorrow after work.
 
Top Bottom