Will not start. Power supply?

Associate
Joined
15 Jul 2010
Posts
72
Hi,
After changing out my DVD drive and giving the inside of PC a clean, the PC will now not start.

All connectors appear to be OK, checked power lead (used one from another PC) still no start. Removed graphic cards, gave another clean, checked connector again, still no go.
The only other thing I can think of is the power supply. Before I remove it and try another (which is a lot of work for me due to very poor health(not covid). I thought I would ask if anyone has suggestions as to what I could try?

Mobo:- GA-Z77-D3H
Power:- Seasonic Prime Gold 1000w 80 plus gold (3 years old)
 
Associate
OP
Joined
15 Jul 2010
Posts
72
Thanks for the replies/help,

No sign of life at all.
Power switch on correct header pins (I have removed and re-seated 3 times).
 
Soldato
Joined
22 Jun 2006
Posts
5,265
You didn't turn the PSU off at the switch did you? I've moved a PC or two and then forgot I did it.
 
Associate
OP
Joined
15 Jul 2010
Posts
72
You didn't turn the PSU off at the switch did you? I've moved a PC or two and then forgot I did it.
I have certainly done that before, but not this time.

I will try another power supply.
I will first just spend some time having a good old grumble at the PC, maybe that will make me feel a little better.
 
Associate
OP
Joined
15 Jul 2010
Posts
72
Used an old power supply to test, and PC started. So switched off and thought to retry original power supply. PC started and got warning that:-
"The main bios is corrupted. The system will be recovered from the backup bios"
Then booted to BSOD, but that due (I think) to the fact I needed to change the bios for the SSD.

Now booting/running, albeit with one graphics card for now. Maybe time for the PC upgrade I have been thinking about for a while.

I have now run out of energy. I need a new power supply for myself lol.

Thank you all for the help. It kept me going.
 
Top Bottom