Windows taskbar long startup

Associate
Joined
3 Mar 2015
Posts
374
Location
Wokingham
The windows taskbar can take up to 5.5 minutes until ready upon login. Until ready the cursor blue-spins when hovered over it.

Scenario:
- Brand new PC build. Formatted NVME. Windows 10 Pro (activated) build 20H2 installed using first admin user (Microsoft Account).
- Applied all Windows updates available. Changed no settings. Installed nothing else. Base install fine.
- Add a second user (family member, Microsoft Account). Wait for PC to set them up. PIN login. Confirm desktop ok. All good. Sign them out.
- Restart PC. Sign in second user. Taskbar takes 5.5 minutes to load.

Most forums recommend Windows repair tips, none of which have helped. The ultimate repair - a fresh install - still has the issue. Booting in Safe Mode still has the issue.

Thus my question here: is it just me? Does anyone else see this when they have a multi-user PC?
 
Associate
OP
Joined
3 Mar 2015
Posts
374
Location
Wokingham
Thanks. I just tried this by turning off all syncing for the second user. Signed the yser out. Signed thd user back in. Taskbar took 4 mins 40 seconds to load in :(

Aldo, uninstalled Skype. Unlinked the Onedrive from this PC. Can see task Manager shows no CPU hogs.
 
Soldato
Joined
7 Jan 2003
Posts
2,943
Location
Offline
Create a standard (non-admin) local user account and check if you have the same issue as the MS account.

All new accounts will run OneDrivesetup.exe at first logon. Wait for this to finish, logout and back in to test.
 
Associate
OP
Joined
3 Mar 2015
Posts
374
Location
Wokingham
Hi,
Same issue for local account, just tested.

I have noticed that the delays occur when I have more than one user signed-in. If I leave one user signed in and then switch to a second user then the taskbar problem happens. If only one user is signed in at a time, windows copes no problem. Does multi-signed-in users exhibit the same issue for anyone else?
 
Last edited:
Associate
OP
Joined
3 Mar 2015
Posts
374
Location
Wokingham
There is a better workaround for this I've now learned, where you don't have to sign out other users.

The problem is related to 'Human Interface Devices' (under Device Manager). One or more USB devices is causing the issue. For me it was a Razer Deathadder V2 mouse.

Steps:
- unplug your USB peripherals except the device(s) you suspect are causing the issue.
- Go into device manager, then open human interface devices.
- select all entries that start 'HID compliant', one by one, snd choose 'disable' if it has thst option available.
- if your mouse is unplugged then you can use windows keyboard shortcuts (tab, arrow keys, enter) to make the change.
- plug back in all your usb devices. Test.

The unplugging of other devices is just to help you disable those problem petipherals and leave the rest untouched. If in doubt, you could choose not to unplug any. Still works.

Post here your findings!
 
Top Bottom