1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

X-Fi died ?

Discussion in 'Sound City' started by stu.artd, 16 May 2006.

  1. stu.artd

    Wise Guy

    Joined: 29 Dec 2003

    Posts: 1,911

    I've had the soundcard for a few months and it's been working fine, used the PC last night and no problems.I switched my PC on today and windows didn't load fully, restarting before the XP login screen appeared. I restarted in safe mode and after trying a couple of things that didn't work I disabled my X-Fi and rebooted - XP loaded OK. I enabled the soundcard again and the PC crashed again - no error message or anything, it just powered off.

    I've tried reinstalling with the drivers from the CD as well as the updated ones from Creative site but the same thing always happens - windows crashes/powers off.

    I have a Soltek SFF and the card is using the only PCI slot. The blue light on the card is illuminated.

    Any opinions ?
     
  2. NqR

    Hitman

    Joined: 8 Sep 2005

    Posts: 537

    Location: Sheffield

    it may sound a bit silly question but have you tried unpluging it and plugin it back?
    Also blow the dust of the pci slot
     
  3. stu.artd

    Wise Guy

    Joined: 29 Dec 2003

    Posts: 1,911

    Thanks for the reply. I seemed to have fixed it by removing the registry groups related to Creative Tech and reinstalling from scratch. It's working for now :)
     
  4. Bony Maloney

    Sgarrista

    Joined: 18 Oct 2002

    Posts: 9,836

    Location: Welsh Wales

    Where you using the Beta drivers that expired today I believe, mine has just died also :)
     
  5. stu.artd

    Wise Guy

    Joined: 29 Dec 2003

    Posts: 1,911

    No, it was just the normal ones. :)
     
  6. Bony Maloney

    Sgarrista

    Joined: 18 Oct 2002

    Posts: 9,836

    Location: Welsh Wales

    I reinstalled the original drivers and no problems now :)
     
  7. mi9tchy

    Hitman

    Joined: 16 Mar 2005

    Posts: 898

    Location: london

    im still using the beta drivers, you can still keep if you remove some of the silly things it puts in your start up, i thought creative were ment to bring out some new ones before these beta's ran out anyway