• Competitor rules

    Please remember that any mention of competitors, hinting at competitors or offering to provide details of competitors will result in an account suspension. The full rules can be found under the 'Terms and Rules' link in the bottom right corner of your screen. Just don't mention competitors in any way, shape or form and you'll be OK.

Errr, new graphics card problem? 6970 lightning

Associate
Joined
8 Feb 2007
Posts
674
Hello every one, got a massive red boxed 6970 delivered today... plugged it in... blank screen, after doing the usual driver reinstalls i opened up GPU-Z to see this...

fy8.png


i'm not an expert but those numbers arent good, especially when compared to the unlocked 6950 i was crossfiring with

h2u.png


Probably a stupid question but this needs to go back huh!!!

Dan
 
Soldato
Joined
5 Sep 2010
Posts
24,783
I assume you've connected two 8 pin PCI-E power cables.

Try the new card by itself in the same PCI-E slot that your existing card was in.
 
Associate
OP
Joined
8 Feb 2007
Posts
674
I assume you've connected two 8 pin PCI-E power cables.

Try the new card by itself in the same PCI-E slot that your existing card was in.

Yup, its got the two 8 pins in and its in the top slot, i chucked out the 6950 from that (which was and still is working fine).

ill try swapping the cards just in case but the stats dont look promising huh
 
Soldato
Joined
6 Aug 2009
Posts
5,816
No wonder they were so cheap ;) Seriously though that looks like an RMA. Worth checking confections etc. as mentioned. Disappointing when things like that happen...
 
Associate
OP
Joined
8 Feb 2007
Posts
674
Weirder, plugged it into slot 3 without the other card and managed to get a picture on it this time... But GPU Z Still showed it whacked! Windows still telling me problem with card, restarted and it's normal? Anyone got an explanation for that then? Lol

Do they take a while to warm up? Lol
Gna plug it back into slot one alone!
 
Soldato
Joined
5 Sep 2010
Posts
24,783
No wonder they were so cheap ;) Seriously though that looks like an RMA. Worth checking confections etc. as mentioned. Disappointing when things like that happen...

The proper Lightning cards should have been fully tested.

It's the ones sold as the Twin Frozr III which are untested and there have been a few problems with.
 
Associate
OP
Joined
8 Feb 2007
Posts
674
8wf.png


Computers really bug me sometimes!! lol

now it appears to be working in the top slot, wonder if it was still using the 6950 drivers based on the that being in the slot previously (even though i did uninstall the cards from device manager and then the CCC)
 
Associate
OP
Joined
8 Feb 2007
Posts
674
oooooook, so did some benching of the lightning on its own, then i put the 6950 back in and the problem has returned? any more ideas?
 
Caporegime
Joined
26 Dec 2003
Posts
25,675
Are you on the latest motherboard BIOS?

Rampage-IV-Extreme BIOS 1202
1.Improve system stability.
2.Improve memory compatibility.
3.Enhance compatibility with some USB devices.
4. Fix PCIEx16 VGA card HD 7970 cannot be detected when the temperature of VGA less than -40.

(I'm guessing it means 40C not -40C?) ah dunno worth a try anyway. :p
 
Last edited:
Soldato
Joined
5 Sep 2010
Posts
24,783
Are you on the latest motherboard BIOS?

Rampage-IV-Extreme BIOS 1202
1.Improve system stability.
2.Improve memory compatibility.
3.Enhance compatibility with some USB devices.
4. Fix PCIEx16 VGA card HD 7970 cannot be detected when the temperature of VGA less than -40.

That wouldn't appear to be relevant:

Hello every one, got a massive red boxed 6970 delivered today...

And assuming -40 isn't a typo then it's only for extreme cooling.
 
Caporegime
Joined
26 Dec 2003
Posts
25,675
Try 1202 it sounds a bit like what you're seeing although it does say -40C.

Ah **** he has a 6970 not 7970 too, my brain is useless today. :(
 
Soldato
Joined
25 Jun 2009
Posts
7,733
remove the card, turn on the computer without a card in it, let it bleep like crazy, turn it off and put the new card back in.
 
Top Bottom