*** HP Reverb G2 Owners Thread ***

Associate
Joined
29 Sep 2020
Posts
47
I assume you’ve made sure it has switched over to the correct audio output?

If so, I get that too (supposedly on the right output, but no audio) and I believe it’s due to usb problems... are you on an AMD board?

Originally I fixed it by uninstalling and reinstalling the device and driver. Recently I’ve found it I turn off the power, start up the WMR portal, then power up the headset the audio works every time... or at least every time so far.
I have checked that it is set to the correct audio output yes, and thanks for the pointers. I did try these today but just no luck. Strange thing is yesterday i got it working and managed to play a game via SteamVR and everything was ok, but today just had no luck.
I am on an MSI X570 motherboard and i know the x570s have been problematic with this headset, hoping it's nothing an update can't fix.
 
Associate
Joined
10 Jul 2020
Posts
223
Just went through the process of disabling SteamVR's motion smoothing and enabling WMR's. It's completely revelatory, in terms of performance alone ACC is like I've never seen it before.

Guide here if anyone needs it: https://docs.microsoft.com/en-us/wi...enabling-motion-reprojection-for-steamvr-apps

So this is using a different method of reprojection than Steam? I'll need to check that out tomorrow.

I tried Assetto Corsa tonight for 5 mins with steam reprojection to get a smoother experience - had most stuff set to low quality and 80fps. Would you run higher settings and WMR reprojection at around 50 to 60 fps?

Also tried a couple mins of Arizona Sunshine.
 
Soldato
Joined
5 Oct 2009
Posts
11,890
Location
Spalding, Lincs
So this is using a different method of reprojection than Steam? I'll need to check that out tomorrow.

I tried Assetto Corsa tonight for 5 mins with steam reprojection to get a smoother experience - had most stuff set to low quality and 80fps. Would you run higher settings and WMR reprojection at around 50 to 60 fps?

Also tried a couple mins of Arizona Sunshine.

How is AC in the G2? Will be one I'll play a fair bit I'd imagine. I enjoyed it with my Rift S but the resolution let it down.
 
Associate
Joined
10 Jul 2020
Posts
223
How is AC in the G2? Will be one I'll play a fair bit I'd imagine. I enjoyed it with my Rift S but the resolution let it down.
At the moment I'm at 80% supersampling and have everything on low quality, so the textures looked a bit soft. But it was very clear and easy to see what's going on. I was hot lapping, well maybe warm lapping to make sure I didn't make myself ill. It's an odd experience going around corners as.the brain expects g force that isn't there. Sitting in an F1 car did feel pretty awesome though.
 
Soldato
Joined
5 Oct 2009
Posts
11,890
Location
Spalding, Lincs
At the moment I'm at 80% supersampling and have everything on low quality, so the textures looked a bit soft. But it was very clear and easy to see what's going on. I was hot lapping, well maybe warm lapping to make sure I didn't make myself ill. It's an odd experience going around corners as.the brain expects g force that isn't there. Sitting in an F1 car did feel pretty awesome though.

That's good to hear.

Yes it's a very weird sensation to begin with but once you get over it, it transforms the game from playing it via a screen!
 
Associate
Joined
2 Dec 2020
Posts
32
Evening all, I've been following this thread and the delivery thread with great interest and found both very helpful. I too received my G2 today once Parcelforce decided they actually might like to deliver it.

I've got everything up and running and now begins the process that others have alluded to with getting my VR legs going. An early comment about not starting with Dirt Rally made me chuckle and was indeed wise. I can confirm from experience now also that rollercoasters aren't a good move either.

So, a silent reader in the background now joins up.. and predictably that's right, I have a problem that I'm hoping someone can help put my mind at rest. So far I've experienced the PSVR briefly so a noob is putting it mildly.

So far I've found similar issues to those already discussed but a couple of ones that I have aren't here and I'm worried I have the first dud of the thread. The first one I experienced was a brief loss of sound, mixed in with a load of crackling in the right ear. It happened for about a minute in Google Earth and a couple of finger taps later and it hasn't done it since. The other issue I have I first noticed in the WMR house. There are some white ghosting effects coming from each visible corner towards the centre of the view. Then when I've just watched the experience in Titanic VR, so all dark backgrounds it's like the lenses are covered in milk it's that bad. If I focus in the middle I also get a sense of a bright light ring the whole way around the combined display, almost like the backlight on a badly built 90's laptop. I've read about god rays and that they're typical with this type of lense but does this sound a bit more severe than that? perhaps light bleed from the LEDs?

I've measured my IPD and come in somewhere around 64.5 to 65 so have tried various settings around that region but with no improvement. I've waited since July, is my wait about to move in to the new year for a replacement or am I fretting about something that just comes with the tech?
 
Associate
Joined
10 Jul 2020
Posts
223
BluecatR I definitely don't have that light bleed from the corner that you mentioned. That doesn't see right.
 
Associate
Joined
2 Dec 2020
Posts
32
I've just been doing a bit of Googling and for sure it seems that the speaker issue is appearing as a common fault. :(
 
Soldato
Joined
21 Jan 2016
Posts
2,513
The speaker thing is likely related to usb issues, will hopefully get resolved. The only time I hear any crackle is when eg I turn on the controllers and the usb connection sound plays.

The light bleed sounds wrong though, have you checked the facial interface is firmly seated? I placed mine down and it picked up a small connector from my messy desktop on one of the magnets and I had a “milky” screen as a result of light bleeding in from the side.

If not, any chance you could try and capture a video/photo of it? God rays definitely still exist in this headset but they are pretty muted, and really only apparent when you have eg black background and white text.
 
Associate
Joined
2 Dec 2020
Posts
32
Definitely seated right yeah, I've taken it off a couple of times and put it back as I thought I could see a tiny bit of ambient light getting in which seemed the opposite of others' experiences. As I've warn it a few times that has gone now and its pitch black inside. I could be being too picky on the WMR house. But if you go and stand out looking at the sea, I can clearly see this ghosting coming in from the bottom corners towards the centre of the display. Then I don't suppose anyone else has Titanic VR? When you're off in the lifeboat looking at the ship the white rays come in so bad from all four corners it's like a jumping to lightspeed scene from star wars.

I've just noticed a tiny little nick in the middle of the right hand lens too. I thought it was a trick of the light earlier when I checked it all over but it's a definite mark now that I look again.
 
Soldato
Joined
23 May 2006
Posts
2,880
Just went through the process of disabling SteamVR's motion smoothing and enabling WMR's. It's completely revelatory, in terms of performance alone ACC is like I've never seen it before.

Guide here if anyone needs it: https://docs.microsoft.com/en-us/wi...enabling-motion-reprojection-for-steamvr-apps
I have read that ACC is a bit of a pig in VR is that not the case with win MR then! The older sibling AC works really well for me I. VR (on my rift and quest at least I have not done racing in the G2 yet)

I bought ACC the day the added VR patch to support them but never played it.
 
Soldato
Joined
23 May 2006
Posts
2,880
I installed reVive and played eleven TT briefly today. It's a 1 off as tetherless on quest is much better....
But tracking held up well. My reach was a little wrong.but I imagine this could be fixed.
There was no haptic feedback at all which is a shame. On the rift pcvr and on quest standalone when I hit the ball I get some feedback which I missed. This could be a revive thing.

In elite I had some very brief flashes up of "you headset is not being tracked" it happened maybe 3 times for a split second over an HR period

But in general tracking held up well.
No crashes last night and pc booted ok so hopefully the inateck card solved that.

I have started pinning a games wall in my cliff House which looks cool..... I put around 25 games on it however I noticed loads of my games are missing when I click view all apps in my windows headset.
I would love to put all my games in there including my Oculus collection in ReVive.

The longer I go on I realise it isn't that comfy on my face. I have it too tight as am trying to improve my FOV. I have a fat head. Skinny heads will get on better I think
All in all I am almost certain I am keeping it . It is so close to being my perfect headset but a few niggles (some completely avoidable without more expense at the design stage) do knock it a bit.


Oh and the cable really got on my nerves . It's not a fault of the cable per se but I have been spoiled by wireless.
 
Last edited:
Associate
Joined
2 Dec 2020
Posts
32
@BluecatR Seems silly to ask, but have the lenses got a protective film on them, that needs removing still?

Sorry no, the blue protective film came off before us. Most scenes it's ok and not noticeable. I've got a good picture that shows the problem, just need to find somewhere to upload it and link it.

This should be on my onedrive now. You can see the rays I'm on about and the bottom left shows what I think are the LEDs that I can also see in certain scenes.

https://1drv.ms/u/s!BA9vlfxGKb71gbRNf_B_TLvygbXeaQ?e=Mm6UER
 
Last edited:
Associate
Joined
18 Sep 2020
Posts
557
Sorry no, the blue protective film came off before us. Most scenes it's ok and not noticeable. I've got a good picture that shows the problem, just need to find somewhere to upload it and link it.

This should be on my onedrive now. You can see the rays I'm on about and the bottom left shows what I think are the LEDs that I can also see in certain scenes.

https://1drv.ms/u/s!BA9vlfxGKb71gbRNf_B_TLvygbXeaQ?e=Mm6UER
Yeah I see them, I dont have mine yet to compare, but that does not seem right to me, maybe send that picture to Sa soon as possible
 
Associate
Joined
27 Jan 2007
Posts
273
I have read that ACC is a bit of a pig in VR is that not the case with win MR then! The older sibling AC works really well for me I. VR (on my rift and quest at least I have not done racing in the G2 yet)

I bought ACC the day the added VR patch to support them but never played it.
ACC is definitely a pig in VR. I've barely used it because it was next to unplayable on my previous setup (1080Ti+VivePro). Got the 3080 last month which definitely improved framerates overall but still had stutters in heavy traffic and/or slow corners where the turn rate is much higher. Despite the increased resolution of the G2, it now feels smoother than ever.

Haven't tried AC yet but am looking forward to that this weekend. Hopefully be able to crank up the supersampling to silly levels.
 
Associate
Joined
2 Dec 2020
Posts
32
SA have passed me over to HP warranty but they tend to agree that it's a faulty unit. At least I can give something to the discussion now and let you all know what going through HP warranty is like.
 
Associate
Joined
29 Sep 2020
Posts
47
SA have passed me over to HP warranty but they tend to agree that it's a faulty unit. At least I can give something to the discussion now and let you all know what going through HP warranty is like.
They advised me to do the same today. So i rang HP and gave them the issues along with serial number, they said they will get back to me within the hour so will be interesting to see what they say.

SA said they will collect the unit from me and issue refund if i can provide them with a DOA letter from HP.
 
Associate
Joined
2 Dec 2020
Posts
32
I guess you are still having the sound issues? I would go for the refund but I got in on the discounted pre-order pricing so all I want is a working headset. They’re on about replacement in 2-3 days once they’re relatively happy its a fault, then I send the faulty one back. Do you know how to get a formal, proper invoice from SA? Never had one by email I don’t think and only a despatch note in the box.
 
Top