Keyboard doesn't work in boot menu

Soldato
Joined
24 Nov 2008
Posts
3,742
Location
ctf_2Fort
Hi there,
Got a new problem now thats only started today :(

When i turn my PC on, i can use the DEL button to get into BIOS, and pressing F12 takes me into the boot menu. That all works fine.

ATM i'm dual booting XP and Win 7 so i get a choice of which OS i want to boot into. When the selection comes up my keyboard stops working. No buttons work at all! Automatically boots me into Win 7 and as Win 7 doesn't have drivers for my wireless adapter I have no internet connection :(

Any ideas on how to fix this? :)

Cheers
 
Soldato
Joined
18 Aug 2007
Posts
9,283
Location
Liverpool
If that doesn't work, is it a USB keyboard? If so look to enable legacy USB in the BIOS; perhaps you inadvertently changed it while mucking around? On some BIOS you might need to set "Plug and play aware OS?" to "No" to accomplish basically the same thing.
 
Soldato
OP
Joined
24 Nov 2008
Posts
3,742
Location
ctf_2Fort
cheers. Got it working now. There was an option in the peripherals bit in BIOS about having a USB keyboard enabled. That was disabled for some reason. Sorted now though :)
 
Associate
Joined
30 Jun 2009
Posts
1,027
Location
Norwich
mostly down to basic driver information installed in the bios to allow usb keyboards to work, that's why in fairness having a ps2 keyboard is handy :)
 
Don
Joined
21 Oct 2002
Posts
46,561
Location
Parts Unknown
it's a silly issue

are these any plus sides to setting it to 'disabled', does anyone know?

ie, why it's it forced on, without the option to disable it?
 
Associate
Joined
30 Jun 2009
Posts
1,027
Location
Norwich
0.0001 of a second or something similar

The more options you have disabled the faster the startup into windows. The only one you really need is boot from hard drive for primary and the rest disabled, that's where more time is lost but it's very very small
 

mrk

mrk

Man of Honour
Joined
18 Oct 2002
Posts
91,616
Location
South Coast
Disable "everything" else?

Lol don't do that...

Unless you mean all other boot options just the drive as 1st boot? won't make a diff still as the 1st boot drive will boot and the 2nd setting onwards ignored unless the 1st boot device fails to boot!

Saving the most time is setting OS drive to 1st boot. Every other option will reduce POST by a minimal amount only. AHCI and RAID controllers will only be enabled if you use them so they're not really an "option" to disable since it's very much needed. AHCI detection is fast anyway.
 
Don
Joined
21 Oct 2002
Posts
46,561
Location
Parts Unknown
dr4g0nf1y, the bios kb driver must take like a millisecond to load

i always disable crap like serial ports, floppy and paralel port
 
Top Bottom