Multicore rendering in L4D.

Associate
Joined
13 Apr 2009
Posts
1,589
Ive been having crashes in L4D, and solved them by disabling MCR, but the thing is my fps have lowered, do you guys know of any fix that could make the game more stable? Oh yeah it happens in TF2 also.

Cheers
 
Associate
Joined
24 Jun 2009
Posts
138
Its happened like that since release of the multicore.
I think they updated it once or twice but its never been perfect, sorry :(
 
Associate
Joined
20 Mar 2006
Posts
692
havent played it for quite a while but always used to have to set mine to disabled otherwise I'd get performance spikes/big stutters
 
Associate
Joined
26 Aug 2006
Posts
1,884
Location
London
It's probably not his overclock, MCR is a bit of a headache in L4D for a lot of people, but maybe.

Anyway, borderless window worked for me, I used to have a lot of stuttering and what not with dual core enabled, plus you get the benefit of instant alt-tabbing.
 
Man of Honour
Joined
13 Oct 2006
Posts
83,133
Like above I have to make sure VSync is disabled to use MCR in L4D with any stability and even then it will randomly fall over - but infrequently enough that I play with it on for the fps boost.
 
Soldato
Joined
10 Jun 2006
Posts
3,870
Location
Wigan
I always keep vsync enabled or I get horrific tearing on most games, when pumping out 100+ frames with a refresh rate of 60hz it doesn't look pretty
 
Soldato
Joined
5 Jun 2005
Posts
20,550
Location
Southampton
any other options i can use to get my speed up, i seem to get slow downs, and they are not lag related, my gcard is getting on a bit 9600GT
 
Joined
5 Oct 2008
Posts
8,925
Location
Kent
It used to be perfect for me with a Quad core, but since i temporarily dropped back to a dual it started to microstutter, so turning it off made it smooth again. Shame really, as I like using multicore capability in games if it is available.
 
Soldato
Joined
5 Jun 2008
Posts
6,238
Location
Portsmouth/Fareham
Driver issue? Just throwing it out there...when I had my 8800GTS I upgraded to the newest drivers Nvidia released one day to get owned by constant "micro stutters". Rolling back fixed the issue and the release after those particular drivers worked fine...
 
Soldato
Joined
5 Jun 2005
Posts
20,550
Location
Southampton
i wish i could upgrade my nvid drivers, on windows 7 i have a strange bug where when i install the latest ones my screen goes a yellow tinge :(
 
Joined
5 Oct 2008
Posts
8,925
Location
Kent
Driver issue? Just throwing it out there...when I had my 8800GTS I upgraded to the newest drivers Nvidia released one day to get owned by constant "micro stutters". Rolling back fixed the issue and the release after those particular drivers worked fine...

Go away knub, you don't play l4d anymore.... :(

(and I'm hurt :mad:)

EDIT: P.S. Thanks for the suggestion. :p
 
Last edited:
Associate
OP
Joined
13 Apr 2009
Posts
1,589
Thanks for all the replies guys;) tbh once again i think im looking to deep into this, its just in certian levels like the drains in death toll were i get about 40fps everywhere else it over 80fps, feel free to trash talk me.:o:(
 
Top Bottom