Random display problem.

Associate
Joined
19 May 2022
Posts
9
Location
Erith Kent
So my PC will at random times turn off my display then the GPU fans will fire up to 100%.Windows is still running in the background and after about 2-3 mins the PC will reboot. Corsair link is showing all temps to be good (GPU idle 36C) (GPU gaming 60C) I've searched the web and so far I have cleaned / re thermal GPU / updated rolled back drivers I have a 1080 GTX which I have tried in both PCI E slots also tried HDMI cable as I use display port cable normally. BIOS is up to date. I took the GPU out and ran onboard graphics (Maximus IX Hero) for 12 hours with no restarts ? How can I troubleshoot the GPU to find out why this is happening ? Thanks in advance
 
Associate
OP
Joined
19 May 2022
Posts
9
Location
Erith Kent
DDU ? sorry being slow or stupid lol what’s that then.

OK so Display Driver Uninstaller but I always perform a clean install ? Run the program so will see what happens. Thx Chris
 
Last edited:
Soldato
Joined
11 Oct 2009
Posts
15,357
Location
Greater London
Is there anything in event viewer when it happens?

What's the full system specs? How are the power cables from the PSU to GPU connected? Is it a cable for each connector or daisy chained? Is there a BIOS switch on the GPU too? Could try flipping that and see if it makes a difference.
 
Soldato
Joined
22 Jun 2006
Posts
5,263
If using onboard graphics fixes it then I can only guess it is the graphics card. Does it have the original BIOS installed? Have you had it since new (if not, did it ever work properly?)?
 
Associate
Joined
19 Aug 2005
Posts
1,021
Location
Beds, UK
What PSU do you have? i had a random restarting issue that was caused by the PSU. It was a quality unit, but was a few years old, and used when i got it. replaced it with a new one and it hasnt done it since.
 
Top Bottom