w/d RMA query

Associate
Joined
6 Jul 2006
Posts
1,507
Location
co durham
sent my drive back last wednesday by royal mail air post,and ive checked my status and it said it hasnt recieved my product yet,i know it says give them 3 days to get it into there system but has anyone had any experience with them thanks
 
Associate
OP
Joined
6 Jul 2006
Posts
1,507
Location
co durham
its ok ive checked again today and they have recieved it and are sending another one out,mine was the old 8mb cache one,never know might get a newer version one like the 16mb cache one :D
 
Soldato
Joined
18 Oct 2002
Posts
10,390
Location
Behind you... Naked!
Thats what they told me...

I got a 36GB one back the other day.

This is NOT a problem at all, and Im a bit iffy in that I prefer a few smaller drives rather than one or two larger ones... always have! - it harks back to my Atari days.

Im only a little bit gutted in that this Drive they gave me was according to the label, manufactured less than 1 week old when I got it...

Surely thats a bit early to take it from its mother?

Its no quicker than the 8MB one I had and in fact I have a sneaky that its slower TBH? - I have a HDTach Reading from when my 8MB 26GB Raptor ran and I will need to dig it out and compare them ( in the same Mobo of course )
 
Associate
OP
Joined
6 Jul 2006
Posts
1,507
Location
co durham
cheers m8,im only going of what they put on the rma web page,they put this is the drive they have sent me WD740ADFD-00NLR1,plus how long did it take to get yours as they said they sent it on the 24th and i checked today and according to ups they cant find the package with the link W/D give me
 
Back
Top Bottom