1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

What else to try before SSD RMA?

Discussion in 'Storage Drives' started by Namsnik, 14 Aug 2014.

  1. Namsnik

    Gangster

    Joined: 27 Jan 2007

    Posts: 245

    Location: Bucks

    I have a OCZ Vertex 2E 120GB 2.5" SATA-II Solid State Hard Drive (OCZSSD2-2VTXE120G), almost 2yrs old. My Bios no longer detects the drive. I tried putting BIOS settings to safe defaults and also tried the drive in a different PC with no success.
    The SSD has a green and a red led - both are lit continuously.

    Is there anything else I can try before RMA ing it?

    (I believe it had a 3yr warranty but haven't found that paperwork yet! So if anyone can confirm please?)
     
  2. lsg1r

    Mobster

    Joined: 25 Jan 2007

    Posts: 3,664

    Location: King's Lynn

    have you checked with a different cable?
    yes I know you've used different pc's but did you use the same cable
     
  3. Namsnik

    Gangster

    Joined: 27 Jan 2007

    Posts: 245

    Location: Bucks

    yep :(
    Even swapped connections from drive in other pc that was working
     
  4. Surveyor

    Capodecina

    Joined: 5 Sep 2010

    Posts: 24,011

    Unless the retailer is going to deal with the RMA you'll need to go through the new company set up by Toshiba - OCZ Storage Solutions.

    OCZ RMA
     
  5. Namsnik

    Gangster

    Joined: 27 Jan 2007

    Posts: 245

    Location: Bucks

    Well the retailer in question delivers "exemplary after care services, where we endeavour to service and cater for any and every customer requirement". Which along with keen prices is why I use them :D

    I had a little data saved on the drive that wasn't backed up so was hoping for some tips like "put it in a freezer for 24hrs" or a magic chant to make it come to life for a while at least. I had been experiencing occaisional problems having to restart several times before I could get through the Bios and into Windows - wrongly assumed to be a Windows issue rather than hardware.
     
    Last edited: 15 Aug 2014
  6. anthony566

    Wise Guy

    Joined: 7 Mar 2013

    Posts: 1,634

    Location: North East

    I think my final check would be to connect it to another PC to confirm the same issues.
     
  7. Vimes

    Mobster

    Joined: 15 Oct 2005

    Posts: 4,858

    Location: Earth, for now

    When that happens (having been there a few times with the 2E's) I have always been told that the drive has locked into a "panic mode" and will need to be RMA'd to be resolved.

    The red and green lit diodes at the back typically means that the drive can only be accessed by OCZ, at least I had never been able to get them working again.

    I did even better than RMA'ing it with my last (and final) 2E drive - I had bought it from a really good retailer who sympathetically, it was out of warranty(ish), did me a straight swap with a Crucial 64GB SSD.

    Thankfully that ended my experiences with OCZ and SSD's...!
     
    Last edited: 15 Aug 2014
  8. wazza300

    Caporegime

    Joined: 11 Jul 2009

    Posts: 27,049

    Location: BenefitStreetBirmingham

    don't you have to leave it unplugged from the sata molex power connector for few hours then try?