1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hazro series - HZ30Wi, HZ30WiQ, HZ27WA, HZ27WB & HZ27WC

Discussion in 'Monitors' started by hazro, Nov 7, 2010.

  1. neologan

    Wise Guy

    Joined: Mar 26, 2003

    Posts: 1,238

    Location: Hertfordshire

    You contacting Hazro about that?
     
  2. chanjy

    Mobster

    Joined: Dec 14, 2003

    Posts: 4,382

    Happy to say that my monitor (27WC) bought in December is still perfectly fine *touches wood

    Not so happy that I still can't see BIOS (ATI 5770), plus faint whine when on full screen internet browser can get quite annoying
     
  3. wapcatlet

    Gangster

    Joined: May 1, 2007

    Posts: 346

    Location: Staffordshire

    Mine also whined but only on certain web sites. The OcUK site was particularly noisy. On a positive note, it stopped whining after 3 weeks and was completely silent. On a negative note, it also stopped displaying a picture after 3 weeks :(
     
    Last edited: Jul 18, 2012
  4. avatar12m

    Hitman

    Joined: Aug 2, 2006

    Posts: 929

    Location: Elloughton, UK

  5. wapcatlet

    Gangster

    Joined: May 1, 2007

    Posts: 346

    Location: Staffordshire

  6. jimhaumman

    Wise Guy

    Joined: May 10, 2012

    Posts: 1,682

    did they do any revision to this monitor,or it stil can happen to monitors overclockers are selling at the moment
     
  7. lukeharvest

    Hitman

    Joined: Dec 3, 2006

    Posts: 730

    Location: Oxford

    Contact OcUK, and ask for a refund, same thing happened to me a couple of months back (monitor was about 7 months old at the time).

    It only seems to be happening to the glass Hazro monitors, which they no longer produce. Hardly surprising though, they stick them on with tape, couldn't believe it when I saw it myself.
     
  8. smilertoo

    Mobster

    Joined: Aug 4, 2005

    Posts: 3,061

    Its a real shame they didn't keep the original casings, they were far superior.
     
  9. PanMaster

    Wise Guy

    Joined: May 12, 2005

    Posts: 1,747

    My BIOS isn't showing on F9 or F10 and there aren't any more BIOS's for the Z77X. I don't won't to keep plugging in the backup monitor.
    It's definitely the motherboard because the HZ27WC worked fine with a S1156 Gigabyte BIOS with the same HD7950 graphics card.

    HELP
     
  10. phinix

    Hitman

    Joined: Feb 13, 2008

    Posts: 664

    Location: Glasgow

    So far my Hazro 27" WC is still good. I had to for more than a year and it all works fine. but that fallen glass looks bad...:eek:
     
  11. mamboboy

    Associate

    Joined: Nov 10, 2011

    Posts: 38

    Those who've sent a glass temptered monitor via courier, how much did it cost?
    I have the WD Hazro, and to be honest, I rarely ever use it's extra features so I've been contemplating selling it and getting a Catleap instead....
     
  12. FallenCow

    Associate

    Joined: Aug 8, 2012

    Posts: 2

    Hi all.. HZ27WC user from the US here. I'm wondering if Hazro still follow up on this board because my front glass has become unglued on the left side and I have been trying to get them to respond to my request for service since MARCH! They offered to replace it with a non-glass front one but ceased all communication after that!

    Anyone with tips on how to get these guys to honor their warranty would be much appreciated!
     
  13. Apem

    Mobster

    Joined: Feb 9, 2009

    Posts: 3,745

    Killer are you mad stick with going dell m8
     
  14. K1LLER HORNET

    Gangster

    Joined: Aug 8, 2010

    Posts: 352

    I will try.
    Gotta keep telling myself that :p

    Quality > Money Saved

    Wish the U2713 would hurry up & get released. Then I can buy it & be done with it :p
     
  15. Noli

    Associate

    Joined: Nov 4, 2009

    Posts: 6

    Not saying I don't believe this - in fact it sounds very believable, but can I just ask where you heard this/how you know this?

    Thks
     
  16. lodiccr

    Associate

    Joined: Oct 18, 2012

    Posts: 1

    My glass also fell off 2 days ago after 11 months of used with no problem, but unfortunately it cracked. (HZ27WD)
    I have emailed ocUK and they advised me to contact Hazro which I did. Judging from the previous forum members experience from HAZRO support services I can only hope they will reply before the warranty runs out.
    I have now stick it back on and was wondering whether I can remove it completely and use it without the glass front. I read on the HAZRO manual warning not to touch the LED screen if the glass is broken.
    Any advise from forum members would be very much appreciated
     
  17. neologan

    Wise Guy

    Joined: Mar 26, 2003

    Posts: 1,238

    Location: Hertfordshire

    i thought hazro's had a two or three year warranty? If so, should be ok.

    I wouldn't try to fix this yourself, just keep using it and don't touch it much, and keep trying to contact hazro until you get an answer.
     
  18. csin82

    Associate

    Joined: Oct 21, 2012

    Posts: 32

    I have to say I was a little worried when ordering my 27WC after seeing this 104 page thread but I'm pleased to say mine arrived on Saturday and is fine - they're clearly not all bad.

    No dead pixels as far as I can tell, no whine, current WC models don't have any glass to fall off - cover is plastic as far as I can tell. I don't do photo work but imho the picture is excellent - as good as the ageing U2407WFP I've replaced colour-wise with a 'cleaner' looking image.

    I will, however, be holding on to that invoice!!
     
    Last edited: Oct 23, 2012
  19. smilertoo

    Mobster

    Joined: Aug 4, 2005

    Posts: 3,061

    I got a 27WD the week they came out and i've had no issues at all with it so far.
     
  20. Edgeuk

    Associate

    Joined: May 6, 2006

    Posts: 19

    I just got a DOA Hazro HZ30Wie (blue light comes on to indicate it's getting a signal and so does the backlight but the screen still remains black) but the sad thing is I have had the monitor since April and only just unboxed it yesterday :o (this was due to house refurb work going on a lot longer than expected)

    My question is to anyone who has dealt with their customer support - what kind of time frame should I be expecting a response to my emails and what sort of time frame should I expect to get a replacement?

    Thanks in advance