1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

The AMD Driver Thread

Discussion in 'Graphics Cards' started by LtMatt, Dec 18, 2014.

  1. Lokken86

    Mobster

    Joined: Mar 8, 2010

    Posts: 4,454

    Location: Aberdeenshire

    Tried the beta drivers. 144hz panel now running at 64hz. Ran Firestrike saw 10fps. Well that was short lived. Off they go I guess.
     
  2. Thekwango

    Capodecina

    Joined: Feb 5, 2009

    Posts: 11,836

    Location: Northern Ireland

    umm....thanks, i think, maybe? :confused::p
    it's weird, been no issues until a week or so ago. i can load my preferred profile and it'll bench perfectly fine, will game perfectly fine then it'll just randomly change values......pumps the clock way up and drops voltage down and bang driver crash. heat isn't an issue as it's under water so am totally baffled by this. will have to dig a bit deeper and see what's going on.
     
  3. humbug

    Caporegime

    Joined: Mar 17, 2012

    Posts: 34,161

    It does not like MSI Afterburner, if it wants to do something different to MSI AB it will have an argument with it and crash.
    The software seems very protective of the hardware, it seems to react even it appears to be fine, it's a pain because I can fine tune it much more than I have but the software says no.
     
  4. SonicSW20

    Hitman

    Joined: Apr 1, 2019

    Posts: 835

    My Vega 56's fans spin up a lot more at idle now even with zero RPM with the 20.5.1 driver. I think I'm going to roll back to the last 20.4.x driver.
     
  5. DragonQ

    Soldato

    Joined: Jun 13, 2009

    Posts: 6,790

    Yesterday I tried Gears 5 and it said there were known compatibility issues with my GPU driver (19.7.1), so I bit the bullet and upgraded to the latest (20.5.1). Performance is still abysmal, constant fps dips and stuttering. Even when the FPS is 70-80 it doesn't feel smooth and it's often dropping to 40 or less. GPU usage is never 100%, and none of my CPU cores are hitting 100% either so I have no idea what's causing the bottleneck. The only information I can find on the net to fix this is (a) detach Bluetooth devices (I don't have any and Bluetooth is disabled in BIOS), and (b) DDU + reinstall GPU driver (which doesn't fix the problem). I also updated to the latest chipset drivers for good measure, still crap.

    No other games I've tried seem to be problematic, so maybe it's just a Gears 5 problem and I'll have to find another game to play. >_>

    Look at this ridiculous CPU bottleneck in the benchmark, can't find any other comparable graphs online with this hardware:

    [​IMG]

    During actual gameplay it's even worse, see how low the GPU usage is:

    [​IMG]
     
    Last edited: Jul 1, 2020
  6. SkeeterUK

    Capodecina

    Joined: Oct 24, 2005

    Posts: 14,830

    Location: North East

    Its probably the weather and also how ur case is with air flow for when its warm days.
     
  7. SonicSW20

    Hitman

    Joined: Apr 1, 2019

    Posts: 835

    Unlikely, its been quite cool the past few days.

    It's not done it once since rolling back just over an hour ago, and it did it 2 or 3 times this morning before rolling back.

    Reported GPU temp in the AMD software is now ~42-44C, this morning it was creeping up to 50C or so, where I assume the trigger point is on the default curve.
     
  8. SkeeterUK

    Capodecina

    Joined: Oct 24, 2005

    Posts: 14,830

    Location: North East

    Ah ok, yeah does sound odd. Probs why there still classed as optional (beta) so theres bugs to be expected and that might be one of em.
     
  9. SonicSW20

    Hitman

    Joined: Apr 1, 2019

    Posts: 835

    Yeah, issues are to be expected. 20.4.2 seems good so far, as long as performance in games is still good I'll wait for the first non beta 20.5.x I think.
     
  10. Thekwango

    Capodecina

    Joined: Feb 5, 2009

    Posts: 11,836

    Location: Northern Ireland

    Ohh ok you might be on to something there, I usually have AB running to display fps, temps and the likes (for no reason other than I’m weird like that) Might uninstall it and see if that makes a difference.
     
  11. Th0nt

    Soldato

    Joined: Jul 21, 2005

    Posts: 7,381

    Location: N.Ireland

    Once I uninstalled it the random quirks went so I dont use AB anymore. I only use OverdriveNTool if I dont tweak in Wattman.
     
  12. SkeeterUK

    Capodecina

    Joined: Oct 24, 2005

    Posts: 14,830

    Location: North East

    afterburner and discord usually cause issues with gaming thats why i never use em and its been better.
     
  13. SonicSW20

    Hitman

    Joined: Apr 1, 2019

    Posts: 835

    It's overlays that often cause issues even if that overlay isn't currently active, just being enabled can cause problems. Usually disabling all overlays and "toast" type notifications fixes the issue.
     
  14. Th0nt

    Soldato

    Joined: Jul 21, 2005

    Posts: 7,381

    Location: N.Ireland

    I noticed people that had more than one display were the proportion of users that had problems.
     
  15. Thekwango

    Capodecina

    Joined: Feb 5, 2009

    Posts: 11,836

    Location: Northern Ireland

    Another interesting discovery that I’d not considered. I recently added a second monitor to my setup. Previously I was using a 1080p 144hz monitor and an ancient 720p tv but bought a 1440 144hz to become my main screen, relegating the 1080 monitor to second screen status and retiring the old tv. That coincides, roughly, with when my issues began. Might just be coincidence but something I’ll have to look at.
    Cheers for posting.
    You don’t happen to have any links to others having issues with second screens and driver weirdness?
     
  16. Phixsator

    Mobster

    Joined: Oct 10, 2012

    Posts: 3,570

    I'm using Discord without issues, though with no overlay(hate it anyway so no loss). My Vega has been running without issue on the latest 20.5.1, but I don't use Afterburner and my PC is pretty barebones right now outside of 3 game launchers and an Android Emulator.
     
  17. Th0nt

    Soldato

    Joined: Jul 21, 2005

    Posts: 7,381

    Location: N.Ireland

    Yeah I have a second screen but only experienced mild issues but you would need to note the driver version - I would probably update it every third release and see if its stable, if it is leave it for a while. Most versions only fix bugs with popular games so if there is no obvious benefit to my vega I leave it alone now.

    In the vega threads and in this thread you will find people on multi-screens having the issues. I think it relates to is they are on a different port type (i.e. one on HDMI and another on DP) or if one is 1080p and the other say 1440p. On one driver release I definitely used to see the wattman crashing and it was something to do with resuming from a sleep or when you turn on after it was off say overnight.
     
  18. SonicSW20

    Hitman

    Joined: Apr 1, 2019

    Posts: 835

    Played some Fallen Order last night, ran great and couldn't tell any performance difference between 20.4.2 and 20.5.1 for that particular title. I'm on the Win 10 ver.2004.

    Not had a single instance of the fans spinning up while not gaming either.
     
  19. henson0115

    Wise Guy

    Joined: Dec 6, 2013

    Posts: 1,090

    Location: Nottingham

    interesting wonder about VR too, mine is disabled most the time but i wonder if it has an impact.
     
  20. LoadsaMoney

    Caporegime

    Joined: Jul 8, 2003

    Posts: 28,892

    Location: In a house