Setting up Pi-hole

Associate
Joined
27 Dec 2003
Posts
1,212
Location
Preston, Lancs
A quick note for those that run pihole from an Ubuntu VM, the minimum Ubuntu version that pihole now supports is 20.04 - just had to upgrade a couple of 18.04 VM instances which I and a friend host.
 
Last edited:
Soldato
Joined
7 Mar 2005
Posts
19,233
Location
LU7
Woke up this morning to find my computer couldn't get online. It had an IP address starting 169.254.x.x. I could get online with my phone once I turned the Wifi off and found there was no VM issues in my area. I was just about able to check my VM hub hadn't re-enabled its DHCP before I lost connection to that. I'd managed to set up a manual IP address for a computer I have downstairs next to the router but then lost connection.

I ended up switching the VM hub off twice and on the second time, with my Pi-Hole not connected to the router, the VM hub worked, had network and Internet access. I was then able to get into the P-Hole to find over 700 errors for this message, "not giving name HOSTNAME to the DHCP lease of ADDRESS because the name exists in SOURCE with address CACHE_ADDR".

I saw that my Pi-Hole DHCP was set to use IP addresses 192.168.0.200 upwards whereas my VM hub was going from 192.168.0.10 so I wonder if the devices couldn't be transferred from their usual range on the VM hub to the 192.168.0.200-251 in the middle of the night? Anyway I have now given my devices a static DHCP lease which I hope will prevent this issue coming back again.
 
Soldato
Joined
7 Mar 2005
Posts
19,233
Location
LU7
That's what I did. Turned DHCP on the VM hub off then activated DHCP on the Pi-Hole. If I could find the logs I could double check the error message and research what caused them but only my Pi-Hole was running the DHCP.
 
Man of Honour
Joined
20 Sep 2006
Posts
33,705
Ah right, I misread. Client DHCP behaviour is a funny thing at times, depending on OS, some refuse to get a new address until you do a release/renew.
 
Soldato
Joined
7 Mar 2005
Posts
19,233
Location
LU7
Ah right, I misread. Client DHCP behaviour is a funny thing at times, depending on OS, some refuse to get a new address until you do a release/renew.
Sorry if I didn't make it clear. I signed into my VM Hub and had the DHCP page open then the same on the Pi-Hole. Turned DHCP off on VM Hub, saved and signed out. Went to Pi-Hole, turned DHCP on and saved. Bit of a learning curve but hopefully now I've told the Pi-Hole to use from 192.168.0.10 upwards instead of from .200 upwards and giving my network devices a static DHCP lease will prevent it from happening again.
 
Soldato
Joined
7 Mar 2005
Posts
19,233
Location
LU7
Hi Feek. Yep I thought when I have a few hours spare I can try the list and see how it works. I don't suppose you've still got your Samsung TV list by any chance?
 
Soldato
Joined
7 Mar 2005
Posts
19,233
Location
LU7
Did you manage to get this up and running fine on your pi?
Not yet, haven't had time to be in front of the TV to test it.
Just use the Perflyst/DandelionSprout Smart-TV Blocklist. It's updated and works, and includes domains for all common SmartTV shenanigans.

PiHole (domain format)
AdGuard Home etc (AdBlock Plus syntax format)
Will give that a go sometime. Thanks.
 
Soldato
Joined
7 Mar 2005
Posts
19,233
Location
LU7
Any news if you managed to get Samsung TV blocked list up & running on pi-hole? Is it effective enough to block ads but still manage to update apps? Cheers

No, I just used the Perflyst/DandelionSprout Smart-TV Blocklist as suggested by Rainmaker. Haven't really checked for ads but will try to tomorrow.
 
Associate
Joined
24 Mar 2018
Posts
1,337
Location
Brighton
Just updated my pihole......

403 Forbidden​

Oh dear!
ls -l
total 20
drwxr-xr-x 2 root root 4096 Jan 21 11:00 conf-available
drwxr-xr-x 2 root root 4096 Jan 21 11:00 conf-enabled
-rw-r--r-- 1 root root 0 Feb 14 2022 external.conf
-rw-r--r-- 1 root root 2959 Jan 21 11:00 lighttpd.conf
-rw-r--r-- 1 root root 5679 Dec 1 20:32 lighttpd.conf.orig

edit:this...
WooT
 
Last edited:
Back
Top Bottom